[Bug 195544] New: panic during "portsnap fetch update"

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Dec 1 02:46:36 UTC 2014


            Bug ID: 195544
           Summary: panic during "portsnap fetch update"
           Product: Base System
           Version: 11.0-CURRENT
          Hardware: arm
                OS: Any
            Status: New
          Severity: Affects Many People
          Priority: ---
         Component: kern
          Assignee: freebsd-bugs at FreeBSD.org
          Reporter: draymond at foxvalley.net

I am using a Raspberry Pi B+ and I am booting from an SD card using a clean
image that has /usr/ports preinstalled.  Next I run "portsnap fetch update" and
it panics around 20 minutes into the operation.

I have tried two different Raspberry Pi B+ units.
I have tried three different USB power cables.
I have tried four different SD cards (Transcend 16GB Class 10, SanDisk 32GB
Class 10, Samsung 32GB Class 6, Kingston 16GB Class 4).

The panic is reproducible regardless of the hardware combination.

This build is otherwise fairly stable (if I don't perform "portsnap fetch
update") depending on the SD card I use.  With the Transcend and Samsung cards
I have been able to build various ports for over 24 hours without a panic. 
However, I did see a panic with the Transcend card after 10 days of heavy use
during an interactive SSH session.  When that happened I could no longer boot
until I reimaged the SD card.  Not sure if this is related.

OS build:
root at raspberry-pi:~ # uname -a
FreeBSD raspberry-pi 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r275002: Mon Nov 24
12:24:16 UTC 2014     root@:/root/crochet/work/obj/arm.armv6/usr/src/sys/RPI-B 

ssh output:
root at raspberry-pi:~ # time portsnap fetch update
Looking up portsnap.FreeBSD.org mirrors... 7 mirrors found.
Fetching public key from isc.portsnap.freebsd.org... done.
Fetching snapshot tag from isc.portsnap.freebsd.org... done.
Fetching snapshot metadata... done.
Fetching snapshot generated at Mon Nov 24 17:13:37 MST 2014:
a9871e18baf0354c1d0795484a204847f79729af04cbfe100% of   70 MB  740 kBps 01m37s
Extracting snapshot... done.
Verifying snapshot integrity... done.
Fetching snapshot tag from isc.portsnap.freebsd.org... done.
Fetching snapshot metadata... done.
Updating from Mon Nov 24 17:13:37 MST 2014 to Mon Nov 24 21:03:40 MST 2014.
Fetching 4 metadata patches... done.
Applying metadata patches... done.
Fetching 0 metadata files... done.
Fetching 66 patches.
(66/66) 100.00%  done.
Applying patches...
Fetching 20 new ports or files... done.
Removing old files and directories...

console output:
dev = mmcsd0s2a, block = 343613, fs = /root/crochet/work/_.mount.freebsd
panic: ffs_blkfree_cg: freeing free frag
KDB: enter: panic
[ thread pid 8 tid 100056 ]
Stopped at      $d:     ldrb    r15, [r15, r15, r15, ror r15]!

You are receiving this mail because:
You are the assignee for the bug.

More information about the freebsd-bugs mailing list