misc/183466: net-im/licq: Don't update to version 1.8.0

Vladimir Omelchuk admin at vladiom.com.ua
Wed Oct 30 06:50:01 UTC 2013


>Number:         183466
>Category:       misc
>Synopsis:       net-im/licq: Don't update to version 1.8.0
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Wed Oct 30 06:50:00 UTC 2013
>Closed-Date:
>Last-Modified:
>Originator:     Vladimir Omelchuk
>Release:        FreeBSD 9.2-RELEASE
>Organization:
>Environment:
FreeBSD vladiom.com.ua 9.2-RELEASE FreeBSD 9.2-RELEASE #1 r255904: Fri Sep 27 09:54:09 EEST 2013     root at vladiom.com.ua:/usr/src/sys/amd64/compile/x64_R92  amd64
>Description:
--->  Upgrading 'licq-base-1.7.1_1' to 'licq-base-1.8.0_1' (net-im/licq)
--->  Building '/usr/ports/net-im/licq'
===>  Cleaning for licq-base-1.8.0_1
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by licq-base-1.8.0_1 for building
===>  Extracting for licq-base-1.8.0_1
=> SHA256 Checksum OK for licq-1.8.0.tar.bz2.
===>  Patching for licq-base-1.8.0_1
===>  Applying FreeBSD patches for licq-base-1.8.0_1
===>   licq-base-1.8.0_1 depends on file: /usr/local/bin/cmake - found
===>   licq-base-1.8.0_1 depends on shared library: libiconv.so.3 - found
===>   licq-base-1.8.0_1 depends on shared library: boost_regex - found
===>  Configuring for licq-base-1.8.0_1
/usr/bin/sed -i.bak -e 's=!/bin/bash=!/usr/local/bin/bash='  /usr/ports/net-im/licq/work/licq-1.8.0/bin/sidclean.sh
===>  Performing in-source build
/bin/mkdir -p /usr/ports/net-im/licq/work/licq-1.8.0
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Found Threads: TRUE  
-- Boost version: 1.52.0
-- Found the following Boost libraries:
--   regex
-- Checking to see if CXX compiler accepts flag -Wall
-- Checking to see if CXX compiler accepts flag -Wall - yes
-- Checking to see if CXX compiler accepts flag -Wextra
-- Checking to see if CXX compiler accepts flag -Wextra - yes
-- Looking for getaddrinfo in socket
-- Looking for getaddrinfo in socket - not found
-- Looking for gethostbyname in nsl
-- Looking for gethostbyname in nsl - not found
-- Looking for readdir_r
-- Looking for readdir_r - found
-- Looking for backtrace
-- Looking for backtrace - not found
-- Looking for prctl
-- Looking for prctl - not found
-- Performing Test ICONV_HAVE_WERROR
-- Performing Test ICONV_HAVE_WERROR - Success
-- Performing Test ICONV_SECOND_ARGUMENT_IS_CONST
-- Performing Test ICONV_SECOND_ARGUMENT_IS_CONST - Success
-- Found Iconv: /usr/local/lib/libiconv.so
-- Looking for DH_free in crypto
-- Looking for DH_free in crypto - found
-- Found OpenSSL: /usr/lib/libssl.so;/usr/lib/libcrypto.so (found version "0.9.8y") 
-- No usable gpgme flavours found.
-- Creating /usr/ports/net-im/licq/work/licq-1.8.0/include/licq/licqversion.h
-- Found Doxygen: /usr/local/bin/doxygen (found version "1.8.3.1") 
-- Generating /usr/ports/net-im/licq/work/licq-1.8.0/Doxyfile
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_C_FLAGS_DEBUG
    CMAKE_MODULE_LINKER_FLAGS
    CMAKE_SHARED_LINKER_FLAGS


-- Build files have been written to: /usr/ports/net-im/licq/work/licq-1.8.0
===>  Building for licq-base-1.8.0_1
Scanning dependencies of target gtest
Scanning dependencies of target gmock_main
Scanning dependencies of target gmock
[  1%] Building CXX object 3rdparty/gtest/CMakeFiles/gtest.dir/src/gtest-all.cc.o
[  3%] Building CXX object 3rdparty/gmock/CMakeFiles/gmock.dir/src/gmock-all.cc.o
[  2%] Building CXX object 3rdparty/gmock/CMakeFiles/gmock_main.dir/src/gmock_main.cc.o
Scanning dependencies of target licq
[  4%] Building CXX object src/CMakeFiles/licq.dir/buffer.cpp.o
/usr/ports/net-im/licq/work/licq-1.8.0/src/buffer.cpp:396: error: no 'void Licq::Buffer::packString16BE(const char*, size_t)' member function declared in class 'Licq::Buffer'
*** [src/CMakeFiles/licq.dir/buffer.cpp.o] Error code 1
1 error
*** [src/CMakeFiles/licq.dir/all] Error code 2
c++: --export-dynamic: linker input file unused because linking not done
c++: --export-dynamic: linker input file unused because linking not done
Linking CXX static library libgmock_main.a
[  4%] Built target gmock_main
c++: --export-dynamic: linker input file unused because linking not done
c++: --export-dynamic: linker input file unused because linking not done
Linking CXX static library libgmock.a
[  4%] Built target gmock
c++: --export-dynamic: linker input file unused because linking not done
c++: --export-dynamic: linker input file unused because linking not done
Linking CXX static library libgtest.a
[  4%] Built target gtest
1 error
*** [all] Error code 2
1 error
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** [do-build] Error code 1

Stop in /usr/ports/net-im/licq.
--->  Skipping 'net-im/licq-qt-gui' (licq-qt4-gui-1.7.1_1) because a requisite package 'licq-base-1.7.1_1' (net-im/licq) failed (specify -k to force)
	! net-im/licq (licq-base-1.7.1_1)	(unknown build error)
	* net-im/licq-qt-gui (licq-qt4-gui-1.7.1_1)

>How-To-Repeat:
portupgrade licq*
>Fix:


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list