misc/183391: 10gigabit networking problems with Emulex OCE 11102 CNA

Antal Pataki pataki.antal at gmail.com
Mon Oct 28 11:20:01 UTC 2013


>Number:         183391
>Category:       misc
>Synopsis:       10gigabit networking problems with Emulex OCE 11102 CNA
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Oct 28 11:20:00 UTC 2013
>Closed-Date:
>Last-Modified:
>Originator:     Antal Pataki
>Release:        FreeBSD 9.2
>Organization:
Granaglia LTd.
>Environment:
FreeBSD storagex.lan.granaglia.com 9.2-RELEASE FreeBSD 9.2-RELEASE #0 r255898: Thu Sep 26 22:50:31 UTC 2013     root at bake.isc.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
>Description:
System setup:
IBM x3500 m4 machine, with 
IBM branded Emulex 11102 CNA (IBM 95Y3764 Emulex 10GbE VFA III for IBM System x)
2xE5-2620 CPU
16GB RAM
IBM ServeRAID M1115 SAS HBA

The installation:
The system contains the 10GbE NIC described above.
The system is direct-connected to an other similar IBM x3500m4 via 10gbit ethernet.
(The other machine originally contains the same Emulex card, but we have Intel X520 NICs too for test.)
FreeBSD 9.2 installed on both machines.

Situations:
1.) Machine1 with Emulex card connected to Machine2 with the same Emulex card
iperf -s on Machine1 and iperf -c on Machine2
The Machine2 hangs up.

2.) Machine1 with Emulex card connected to Machine2 with the same Emulex card
iperf -c on Machine1 and iperf -s on Machine2
The Machine1 hangs up.

3.) Machine1 with Emulex card connected to Machine2 with Intel X520 card
iperf -c on Machine1 and iperf -s on Machine2
The Machine1 hangs up.

3.) Machine1 with Intel X520 card connected to Machine2 with Emulex card
iperf -c on Machine1 and iperf -s on Machine2
No any machine hangs up, the iperf runs perfectly.

It seems, if any machine contains the Emulex card, and runs iperf -c , it will hangs up.

With heavy traffic (about over 5Gbit/sec) hangs up the machine that contains the Emulex card, too, no only the iperf -c.
>How-To-Repeat:
Install Emulex OCE 11102 CNA to a FeeeBSD 9.2 system.
Connect it to an other machine via 10gbit ethernet.
Start iperf -c on the machine with the Emulex card.
The machine will hangs up.
>Fix:


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list