misc/182884: FreeBSD HVMPV domU networking does not work

Hugo Silva hugo at barafranca.com
Thu Oct 10 21:30:00 UTC 2013

>Number:         182884
>Category:       misc
>Synopsis:       FreeBSD HVMPV domU networking does not work
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Oct 10 21:30:00 UTC 2013
>Originator:     Hugo Silva
>Release:        10.0-ALPHA5
FreeBSD iscsi 10.0-ALPHA5 FreeBSD 10.0-ALPHA5 #0 r256092: Sun Oct 6 22:30:23 UTC 2013 root at snap.freebsd.org:/usr/obj/usr/src/sys/sys/GENERIC amd64
Under a NetBSD 6.1.2/amd64 and Xen 4.2.3, FreeBSD 10.0-ALPHA5 network is unstable/unusable.

Trying to ssh in to the virtual machine does not work.

On the first attempt, ssh from the client hung in connect() and at the FreeBSD domU console there was a panic[1].

On the dom0 console, the following was shown:
xvif3i0: packet size 1610 too big
xvif3i0: packet size 0 too big
xvif3i0: packet size 1544 too big

Disabling txcsum and rxcsum[2] makes the client hang in select() instead, but on the FreeBSD we still see "xn_txeof: WARNING: response is -1!", while simultaneously on the dom0 the following is printed to the system console: "xvif5i0: packet cross page boundary". The SSH connection is of course never established.

[1] https://webmail.ami.org.pt/panic.jpg
[2] http://lists.freebsd.org/pipermail/freebsd-xen/2011-May/000940.html -- I saw & reported this same error on 9.x two years ago. It was fixed. Also, I run a 10-CURRENT snapshot from maybe half a year ago and everything works as expected there as well.



More information about the freebsd-bugs mailing list