graphics/dri

Michael Henze tzoi516 at gmail.com
Thu Nov 21 00:06:59 UTC 2013


I have updated gcc and clang, and have tried various /etc/make.conf options
but I still can't compile graphics/dri for an Intel HD Graphics 3000 laptop
with the NEW_XORG and KMS options. Here are the errors:

In file included from i830_context.c:28:
In file included from ./i830_context.h:31:
../../../../../src/mesa/drivers/dri/intel/intel_context.h:249:4: error:
unknown type name 'drm_intel_context'
   drm_intel_context *hw_ctx;
   ^
1 error generated.
gmake[6]: *** [i830_context.lo] Error 1
gmake[6]: Leaving directory
`/ram/usr/ports/graphics/dri/work/Mesa-9.1.6/src/mesa/drivers/dri/i915'
gmake[5]: *** [all-recursive] Error 1
gmake[5]: Leaving directory
`/ram/usr/ports/graphics/dri/work/Mesa-9.1.6/src/mesa/drivers/dri'
gmake[4]: *** [all-recursive] Error 1
gmake[4]: Leaving directory
`/ram/usr/ports/graphics/dri/work/Mesa-9.1.6/src/mesa/drivers'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory
`/ram/usr/ports/graphics/dri/work/Mesa-9.1.6/src/mesa'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory
`/ram/usr/ports/graphics/dri/work/Mesa-9.1.6/src/mesa'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory
`/ram/usr/ports/graphics/dri/work/Mesa-9.1.6/src'
gmake: *** [all-recursive] Error 1
*** [do-build] Error code 1

Stop in /usr/ports/graphics/dri.

===>>> make failed for graphics/dri

Any suggestions is greatly appreciated. I do use ccache, but I have tried
compiling without it and still get the same errors.


More information about the freebsd-bugs mailing list