misc/173718: phantom directory in zraid2 pool

Brian Gold bgold at simons-rock.edu
Mon Nov 19 13:30:01 UTC 2012


>Number:         173718
>Category:       misc
>Synopsis:       phantom directory in zraid2 pool
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Nov 19 13:30:00 UTC 2012
>Closed-Date:
>Last-Modified:
>Originator:     Brian Gold
>Release:        9.0-RELEASE
>Organization:
Bard College at Simon's Rock
>Environment:
FreeBSD phoenix2.simons-rock.edu 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan  3 07:46:30 UTC 2012     root at farrell.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64
>Description:
I am running a zraid2 pool (v28) on 6 sata drives which are passed through a Dell SAS 6/iR running in TI mode for pass-through. This FreeBSD server functions as backup storage for our site. All of our servers are rsynced over to this server each night for backup.

Recently, I've noticed that I will get messages like the following in my rsync log:
file has vanished: "/backup/ldap1/etc/pki"

Now, usually when I get a file has vanished error during an RSYNC run, it indicates that the source file/directory on the system that is sending the rsync backup has been deleted or moved before rsync got a chance to actually send it. That doesn't appear to be the case here. "/backup/ldap1/etc/pki" is the destination directory on my Freebsd/ZFS server. I take a look in "/backup/ldap1/etc" on my Freebsd server and the "pki" subdirectory is no longer listed.

Ok, so I run "mkdir /backup/ldap1/etc/pki" and get the following error: "mkdir: /backup/ldap1/etc/pki: File exists". Odd

Just to double check, I run "ls -la /backup/ldap1/etc/pki" and get the
following: "ls: /backup/ldap1/etc/pki: No such file or directory"

I then run a simple ls on the directory: "ls /backup/ldap1/etc" and the pki subdirectory shows up just fine.


>How-To-Repeat:
I have no idea how to cause this issue on another system unfortunately. I did however locate a few postings on the forums of other users who experienced similar issues.
http://lists.freebsd.org/pipermail/freebsd-current/2011-October/027902.html
>Fix:
Eventually, I decide to manually delete the entire "/backup/ldap1" directory and all of its contents. Everything deletes just fine, except for the directories that were erroring in my rsync logs. I then re-run my rsync job and those directories are populated without issue.

Now however, I am getting different directories erroring during the nightly rsync:
"/backup/ldap1/var/lib/yum/yumdb/i/8b1b1eb729e16ac4c3d877718de59d12b2ee7c2a-iso-codes-3.16-2.el6-noarch" failed: No such file or directory (2)"

And from my daily security email output:
Checking setuid files and devices:
find: /backup/ldap1/var/lib/yum/yumdb/c/1e68056c53f1cd6b5ddf78fc18e8fcada22d89d9-cdparanoia-libs-10.2-5.1.el6-x86_64/from_repo_revision: No such file or directory
find: /backup/ldap1/var/lib/yum/yumdb/i/8b1b1eb729e16ac4c3d877718de59d12b2ee7c2a-iso-codes-3.16-2.el6-noarch: No such file or directory


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list