misc/169428: ugen not detecting all endpoints on device

Frank Greco Frank.Greco2 at va.gov
Mon Jun 25 19:10:08 UTC 2012

>Number:         169428
>Category:       misc
>Synopsis:       ugen not detecting all endpoints on device
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Jun 25 19:10:08 UTC 2012
>Originator:     Frank Greco
>Release:        7.4, 8.1 and 9.0
FreeBSD hpapa.greconet 8.1-RELEASE FreeBSD 8.1-RELEASE #0: Mon Jul 19 02:36:49 UTC 2010 root at mason.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC amd64
Starting with FreeBSD 4.2 I had written a C program to control a USB spectrometer (Ocean Optics USB2000). The device always appeared as ugen with two control points, e.g., ugen0.2 and ugen0.7. My program worked through FreeBSD 7 but I have not been able to get it to work with either 8 or 9. In both it appears as only one ugen device, e.g., ugen0.4. I was hoping this issue would get solved along the way, but I am now worried that when FreeBSD 7.4 is no longer supported, that I may get stuck. Any advice would be appreciated.

One of the endpoints, ugen0.2, is for transmitting commands and reading spectra. The other enpoint, ugen0.7, is for receiving current instrument settings only. I suspect, but I have not been able to demonstrate, that it's only the latter endpoint that is showing up. I don't get any response from transmitted commands, which is what would be expected from that endpoint. Everything still works fine in FreeBSD 7, so it's not the instrument.

Thanks for considering this.



More information about the freebsd-bugs mailing list