misc/168938: moused enabled causes xorg startx to fail

J B jb.1234abcd at gmail.com
Mon Jun 11 20:57:12 UTC 2012


On Mon, Jun 11, 2012 at 9:16 AM, J B <jb.1234abcd at gmail.com> wrote:
> This is a bit strange.
> To fix the problem I disabled moused in /etc/rc.conf .
> I could 'startx' X session.
> But 'ps' still showed moused processes:
> $ ps auxww |grep -i mouse
> root        1286   0.0  0.1   9716   1148  ??  Ss    8:55AM  0:01.02
> /usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid
> root        1888   0.0  0.1   9716   1144  ??  Is    8:55AM  0:00.00
> /usr/sbin/moused -p /dev/psm0 -t auto
> root        2045   0.0  0.1  12340   2516  ??  I     8:55AM  0:00.01
> hald-addon-mouse-sysmouse: /dev/psm0 (hald-addon-mouse-sy)
> root        2065   0.0  0.1  12340   2520  ??  I     8:55AM  0:00.01
> hald-addon-mouse-sysmouse: /dev/ums0 (hald-addon-mouse-sy)
> jb          2262   0.0  0.1   9748   1284   2  S+    9:03AM  0:00.01
> grep -i mouse
>
> I have 2 mouses: Lenovo thinkpad stick and external usb mouse.

Oops, I must have goofed.
Disabling moused in rc.conf did just that for the default (built-in) mouse.
$ ps auxww|grep -i mouse
root        1938   1.0  0.1  12340   2628  ??  S    10:31PM 0:00.92
hald-addon-mouse-sysmouse: /dev/psm0 (hald-addon-mouse-sy)
root        1287   0.0  0.1   9716   1148  ??  Ss   10:31PM 0:00.12
/usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid
root        1958   0.0  0.1  12340   2516  ??  I    10:31PM 0:00.01
hald-addon-mouse-sysmouse: /dev/ums0 (hald-addon-mouse-sy)
jb          2110   0.0  0.0   1928    708   1  R+   10:34PM 0:00.02
grep -i mouse

No problem with moused here.


More information about the freebsd-bugs mailing list