kern/164082: recurring problem wirh /dev/console and syslog handling

Claude Buisson clbuisson at
Fri Jan 13 13:00:25 UTC 2012

>Number:         164082
>Category:       kern
>Synopsis:       recurring problem wirh /dev/console and syslog handling
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri Jan 13 13:00:24 UTC 2012
>Originator:     Claude Buisson
>Release:        8.2-STABLE 9.0-CURRENT
FreeBSD 9.0-PRERELEASE #0: Sat Dec  3 16:59:34 CET 2011
    toor at inspiron:/usr/obj/home/src/sys/INSPIRON9X i386

This problem may be traced back to 8.0-CURRENT, and the first symptom was the
fact that xconsole and xterm -C stopped displaying console messages. This was
acknowledged by Ed Schouten in [1]

To work around this problem I patched src/sys/security/mac_stub/mac_stub.c, so
as to get stub_priv_grant() return 0 for PRIV_TTY_CONSOLE.
Others [2] [3] patched src/sys/kern/tty.c.

This worked BUT:

The kernel messages got displayed by xconsole or xterm -C, but not the messages
sent to /dev/console via syslog.

My current workaround is to use xterm -C running a

  sudo watch /dev/ttyv0

the -C is needed for the kernel messages, and the watch for the syslog messages.

This worked with 8.X-STABLE, BUT:

After intalling a 9.0-CURRENT svn r224294 (I have not tested a previous
revision), I found that some kernel messages are displayed as blank/empty lines
in the xterm -C. See [4] for geli/geom_eli messages, such as

cryptosoft0: <software crypto> on motherboard
GEOM_ELI: Device ada0p9.eli created.
GEOM_ELI: Encryption: AES-XTS 128
GEOM_ELI:  Integrity: HMAC/SHA256
GEOM_ELI:     Crypto: software

This is also true for umass messages like:

da0: 40.000MB/s transfers





More information about the freebsd-bugs mailing list