kern/165212: No WiFi on Acer Aspire One 751h (Atheros AR5BHB63 & AR5B95)

Dave Mischler jake at
Thu Feb 16 20:10:10 UTC 2012

>Number:         165212
>Category:       kern
>Synopsis:       No WiFi on Acer Aspire One 751h (Atheros AR5BHB63 & AR5B95)
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Feb 16 20:10:09 UTC 2012
>Originator:     Dave Mischler
>Release:        10-CURRENT
FreeBSD 10.0-CURRENT FreeBSD 10.0-CURRENT #3: Wed Feb 15 16:38:41 EST 2012     mischler at  i386
Nothing is ever received by ath0 on an Acer Aspire One A0751h-1279 under 8.2, 9.0-RELEASE, 9.0-STABLE or 10.0-CURRENT.  It works on Ubuntu-10.10 (only version I tried).  I also tried an AR5B95 card, and had the same results (works on Ubuntu, not on FreeBSD).

I had the PCI mapping problem under 8.2 (see for more info).  I discussed this matter on freebsd-wireless starting with

Here is what shows up in for ath0 with the AR5BHB63

ath0: <Atheros 5424/2424> mem 0xd0000000-0xd000ffff irq 17 at device 0.0
on pci3
ath0: AR2425 mac 14.2 RF5424 phy 7.0

and this is what shows up from pciconf -lv:

ath0 at pci0:3:0:0:	class=0x020000 card=0xe00d105b chip=0x001c168c rev=0x01
    vendor     = 'Atheros Communications Inc.'
    device     = 'AR242x / AR542x Wireless Network Adapter
    class      = network
    subclass   = ethernet

I boot the system and run the following commands and never get any

ifconfig wlan0 create wlandev ath0
ifconfig wlan0 up scan
ifconfig wlan0 list scan

Try to connect to a WiFi network with an Acer Aspire One A0751h-1279 netbook running FreeBSD 8.2 or later.



More information about the freebsd-bugs mailing list