misc/165140: mount_msdosfs -W koi2dos cannot read file No.

Andriy Gapon avg at FreeBSD.org
Thu Feb 16 08:50:15 UTC 2012


The following reply was made to PR misc/165140; it has been noted by GNATS.

From: Andriy Gapon <avg at FreeBSD.org>
To: Thor Ablestar <thor at irk.ru>
Cc: bug-followup at FreeBSD.org
Subject: Re: misc/165140: mount_msdosfs -W koi2dos cannot read file No.
Date: Thu, 16 Feb 2012 10:45:19 +0200

 on 16/02/2012 06:07 Thor Ablestar said the following:
 > On 02/16/12 00:04, Andriy Gapon wrote:
 >> 1. Do I understand correctly that /usr/src/sbin/mount_msdosfs/mount_msdosfs.c
 >> takes the conversion table from /usr/ports/converters/libiconv ?
 >> Well, as unexpected as it is, the answer is yes.
 > Well. Ugly hack to add koi-8 0xa9 "(c)" character as a replacement for Unicode
 > 0x2116 "No."  character to libiconf's lib/koi8r.h succeeded (Reboot was needed).
 > Thanks, problem temporarily solved but I still believe that it should be solved
 > permanently by the FreeBSD team in official way.
 
 GOTO 10
 
 :-)
 
 (FreeBSD doesn't need to grow hacks without necessity.  If you want some symbol,
 use a locale/charset that has it).
 
 -- 
 Andriy Gapon


More information about the freebsd-bugs mailing list