kern/171121: bge driver not working with BCM5719 (HP Proliant DL 360 G8)

Anders Nordby anders at FreeBSD.org
Mon Aug 27 19:50:03 UTC 2012


>Number:         171121
>Category:       kern
>Synopsis:       bge driver not working with BCM5719 (HP Proliant DL 360 G8)
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Aug 27 19:50:02 UTC 2012
>Closed-Date:
>Last-Modified:
>Originator:     Anders Nordby
>Release:        9.1-PRERELEASE
>Organization:
-
>Environment:
First tried with FreeBSD-9.0-RELENG_9-20120701-JPSNAP-amd64, later testing with:
FreeBSD  9.1-PRERELEASE FreeBSD 9.1-PRERELEASE #2: Wed Aug 22 15:45:03 CEST 2012     root at foo:/usr/obj/usr/src/sys/GENERIC  amd64

>Description:
I'm having lots of difficulties with BCM5719, which is the default
network card of HP Proliant DL 360 G8 servers. I can get a few ping
replies before I get a couple of these:

bge0: watchdog timeout -- resetting
bge0: watchdog timeout -- resetting

Then everything hangs. Can not log in using ssh.

I'm running: FreeBSD-9.0-RELENG_9-20120701-JPSNAP-amd64

Info about the NIC:

# devinfo -rv | grep phy
                brgphy0 pnpinfo oui=0x1be9 model=0x22 rev=0x0 at phyno=1
                brgphy1 pnpinfo oui=0x1be9 model=0x22 rev=0x0 at phyno=2
                brgphy2 pnpinfo oui=0x1be9 model=0x22 rev=0x0 at phyno=3
                brgphy3 pnpinfo oui=0x1be9 model=0x22 rev=0x0 at phyno=4
# grep bge /var/run/dmesg.boot
bge0: <Broadcom unknown BCM5719, ASIC rev. 0x5719001> mem
0xf6bf0000-0xf6bfffff,
0xf6be0000-0xf6beffff,0xf6bd0000-0xf6bdffff irq 32 at device 0.0 on pci3
bge0: CHIP ID 0x05719001; ASIC REV 0x5719; CHIP REV 0x57190; PCI-E
miibus0: <MII bus> on bge0
bge0: Ethernet address: 2c:76:8a:54:08:14
bge1: <Broadcom unknown BCM5719, ASIC rev. 0x5719001> mem
0xf6bc0000-0xf6bcffff,
0xf6bb0000-0xf6bbffff,0xf6ba0000-0xf6baffff irq 36 at device 0.1 on pci3
bge1: CHIP ID 0x05719001; ASIC REV 0x5719; CHIP REV 0x57190; PCI-E
miibus1: <MII bus> on bge1
bge1: Ethernet address: 2c:76:8a:54:08:15
bge2: <Broadcom unknown BCM5719, ASIC rev. 0x5719001> mem
0xf6b90000-0xf6b9ffff,
0xf6b80000-0xf6b8ffff,0xf6b70000-0xf6b7ffff irq 32 at device 0.2 on pci3
bge2: CHIP ID 0x05719001; ASIC REV 0x5719; CHIP REV 0x57190; PCI-E
miibus2: <MII bus> on bge2
bge2: Ethernet address: 2c:76:8a:54:08:16
bge3: <Broadcom unknown BCM5719, ASIC rev. 0x5719001> mem
0xf6b60000-0xf6b6ffff,
0xf6b50000-0xf6b5ffff,0xf6b40000-0xf6b4ffff irq 36 at device 0.3 on pci3
bge3: CHIP ID 0x05719001; ASIC REV 0x5719; CHIP REV 0x57190; PCI-E
miibus3: <MII bus> on bge3
bge3: Ethernet address: 2c:76:8a:54:08:17

Searching other bug reports and posts, I've tried:

hw.bge.allow_asf="0"
hw.pci.enable_msi="0"

But it didn't help. Any ideas?

If I don't use the loader.conf settings above, I also get (before the
watchdog timeouts):

bge0: 2 link states coalesced
bge0: 2 link states coalesced
bge0: 2 link states coalesced

>How-To-Repeat:

>Fix:


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list