kern/156691: panic when using hard disks as RAW devices within VMWare ESXi 4.1-u1

Helmut Schneider jumper99 at
Thu Apr 28 09:30:13 UTC 2011

>Number:         156691
>Category:       kern
>Synopsis:       panic when using hard disks as RAW devices within VMWare ESXi 4.1-u1
>Confidential:   no
>Severity:       critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Apr 28 09:30:12 UTC 2011
>Originator:     Helmut Schneider
>Release:        8.2-RELEASE-p1
Within VMWare ESXi 4.1-u1 I created RAW devices using When I install FreeBSD the filesystem gets corrupted (IIRC during the installation "ELF interpreter /libexec/ not found
" pops up many times). Also, when I copy a large number of files or directories to the devices (tried cp, dump/restore and rsync) the VM panics immediately. Unfortunately /var/crash remains empty after reboot. If there is another way to create a backtrace please advice.

Disks are 2 seagate 80GB SATA and one seagate 400GB SATA-II

Using FreeBSD 8.x I can

- partition and label the disks
- copy a few files to it, create a few directories on it

I tested the following OSses within the same VM using the same RAW devices and they install and operate fine:

Windows 7
Ubuntu 10.4
OpenBSD 4.8

The disks were all tested with seatools which reported no errors. I can also install and use the disks without problems on a physical machine.

After the crash/panic most of the time the data on the first MBR-UFS partition (and only the first partition!) is complete rubbish, after fsck only a few files within lost+found remain. Sometimes also all labels are gone but are easily restoreable using bsdlabel -R.

The problem is easily reproducable (here).

I tried with open-vm-tools-nox11-313025_2 and without, also booting mfsbsd and then copy files.
Run ESXi 4.1-u1
Create RAW devices according to
Install FreeBSD on it


More information about the freebsd-bugs mailing list