misc/143077: logcheck didn't work after upgrade to 1.2.54

Berend de Boer berend at pobox.com
Fri Jan 22 06:40:01 UTC 2010

>Number:         143077
>Category:       misc
>Synopsis:       logcheck didn't work after upgrade to 1.2.54
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri Jan 22 06:40:00 UTC 2010
>Originator:     Berend de Boer
>Release:        6.4-STABLE
FreeBSD bmach.nederware.nl 6.4-STABLE FreeBSD 6.4-STABLE #5: Mon Jan  4 10:22:51 NZDT 2010     root at bmach.nederware.nl:/usr/obj/usr/src/sys/BMACH  i386

Logcheck failed with:

Could not run logtail or save output

Check temporary directory: /tmp/logcheck.urOJdC

Also verify that the logcheck user can read all files referenced in

This is a misleading message. Logcheck could read those files. It appears that the problem was with logtail2:

/usr/local/sbin/logtail2 /var/log/messages

This failed with:

cannot compile /usr/local/share/logcheck/detectrotate/10-savelog.dtr: Permission denied


chown this directory to logcheck solved the problem. Next thing was a complaint about messages.offset. After chowning that and auth.log.offset to logcheck, logcheck worked again.


More information about the freebsd-bugs mailing list