kern/153205: PIONEER DVD-RW: timeout with ahci(4), OK with ata(4) + ATA_CAM

Dmitry Pryanishnikov lynx.ripe at
Thu Dec 16 08:50:07 UTC 2010

>Number:         153205
>Category:       kern
>Synopsis:       PIONEER DVD-RW: timeout with ahci(4), OK with ata(4) + ATA_CAM
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Dec 16 08:50:06 UTC 2010
>Originator:     Dmitry Pryanishnikov
>Release:        RELENG_8
FreeBSD lynx.homenet 8.2-PRERELEASE FreeBSD 8.2-PRERELEASE #1: Thu Dec 16 01:36:59 EET 2010     root at lynx.homenet:/databig/obj/databig/ftp/RELENG_8/src.101215/sys/lynx  amd64

Hardware: INTEL D975XBX2 mb, Intel Core2 Quad CPU (Q6600), 8Gb of ECC RAM, PATA HDD (SAMSUNG SP1614N), SATA HDD (Seagate ST31000520AS), SATA DVD-RW (PIONEER DVR-215D). Both SATA HDD and SATA DVD-RW are connected to Intel ICH7 SATA300 controller. Worked w/o problems using old ata(4) driver, still works OK using ata(4) in ATA_CAM mode. However, loading ahci(4) results in HDD still working, but DVD-RW doesn't even get detected during the boot (I've tried different SATA ports on this controller and different SATA cables - results are the same).

Kernel configuration:

loader.conf for ata(4) case (for using ahci(4) I simply load it from the loader's prompt):

Verbose dmesg w/o ahci module (DVD-RW attached by ata(4) and works OK):

Verbose dmesg with ahci module (DVD-RW does not attach):

I'm ready to provide any additional information about this HW and try patches on it.



More information about the freebsd-bugs mailing list