conf/145613: booting from zfs root not working

Frank Bartels freebsd at
Sat Apr 10 17:30:08 UTC 2010

>Number:         145613
>Category:       conf
>Synopsis:       booting from zfs root not working
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sat Apr 10 17:30:03 UTC 2010
>Originator:     Frank Bartels
>Release:        7.3-RELEASE
FreeBSD glas 7.3-RELEASE FreeBSD 7.3-RELEASE #2: Wed Apr  7 02:59:36 CEST 2010     knarf at glas:/usr/obj/usr/src/sys/GLAS  i386
I've used to install FreeBSD 8.0 on zfs root before successfully (more than once, i386 and amd64).

Because I've seen FreeBSD 7.3-RELEASE now supports gptzfsboot without the need to recompile the loader (LOADER_ZFS_SUPPORT=YES is now the default), I'm trying to migrate an existing 7.3-RELEASE machine to zfs root.

After spending one day on trying the second advertised feature in the 7.3 announcement ("new boot loader gptzfsboot supports GPT and ZFS") I found the little note in ERRATA that zfsloader is not zfs aware.

So I've added the patch from and tried again. But without success.

I see the BTX loader, then the ZFS aware loader (which again tells me "BIOS drive C: is disk0" - this does not happen under 8.0) and then it scrolls very fast and the screen is full of

forth not found
builtin not found
only not found

Because this machine is more or less production, I've set up four different FreeBSDs in VirtualBox.

8.0-RELEASE amd64: zfs root works fine
8.0-STABLE amd64: zfs root works fine
7.3-RELEASE amd64: zfsloader fails with "FATAL: int13_harddisk: function 42. Can't use 64bits lba" 
7.3-STABLE amd64: zfsloader fails with "FATAL: int13_harddisk: function 42. Can't use 64bits lba"

So I'm not able to reproduce the same error with VirtualBox but a new one that also does not occur under 8.

[I'd like to upgrade to 8, too, but this machine is using vlan+lagg+em which is broken in 8].
Install 7.3-RELEASE using (7.3's gpart works a bit "different" - you'll need a calculator for the -b and -s parameters).

In step 2.7. apply the patch for sys/boot/i386/loader/Makefile and follow the compile/install steps.

Try to boot from the new hard disk. It will fail.


More information about the freebsd-bugs mailing list