conf/145311: loader.conf can cause boot hang

Henry Grebler henrygrebler at
Sun Apr 4 08:34:29 UTC 2010

Hi Garrett,

-->    I may be incorrect, but the reason why it's doing this instead of
-->checking is because the kernel hasn't loaded yet, and thus it hasn't
-->determined that the ukbd module is or is not loaded in the monolithic
-->kernel image (someone please correct me if I'm wrong). 

No, I don't think that's right. I did some other tests. I did an
explicit "unload" (which unloads the kernel).

OK unload
OK load ukbd
elf32_loadfile: can't load module before kernel
can't load file '/boot/kernel/ukbd.ko': operation not permitted

It says that I can't load ukbd.ko before I've loaded the kernel.

-->                                                       The loader does
-->actually cache which modules have been loaded though so you can't load
-->a module twice.

That's correct. I confirmed that when I did this:

OK load ukbd
/boot/kernel/ukbd.ko text=...
OK load ukbd

The first time, it loads a module. The second time, it does nothing.

-->    It can exist in the monolithic kernel image, or outside of the
-->kernel image as a module; it's up to you how you want to install

I'm using the standard 8.0 kernel. I have not recompiled.

On the one hand, the fact that, on the first "load ukbd", it gives the
message that it is loading a module suggests that ukbd is not loaded
in with the kernel. On the other hand, since my USB keyboard works, I
would conclude that a driver has been loaded. I just don't get it.

-->    Another final thing worth trying (if you haven't tried the BIOS
-->support change I suggested yet), is to boot up the system without
-->snd_ich, but after the system is booted up try loading snd_ich.

Yes, I did that when I first installed audio; and again when I found I
could avoid the hang by having nothing in loader.conf. I simply
manually typed "kldload snd_driver" and sound worked fine. No freezes
(because it is long past booting).
-->                                                                Does
-->the system still freeze up? Also, have you tried loading snd_ich and
-->ukbd in reverse order, i.e.:
-->load snd_ich
-->load ukbd

Yes, see point 6 in my previous email.


More information about the freebsd-bugs mailing list