kern/141011: Encrypted root, geli password at boot; enter key never released

Normand Leclerc leclercn at
Mon Nov 30 03:00:12 UTC 2009

>Number:         141011
>Category:       kern
>Synopsis:       Encrypted root, geli password at boot; enter key never released
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Nov 30 03:00:11 UTC 2009
>Originator:     Normand Leclerc
>Release:        8.0
New install using abd64 GENERIC kernel (can't actually boot right now).
  I just finished installing the new release 8.0 on a mini-ITX PC (Intel Atom boxd945gclf2 motherboard based).  The kernel I used is the GENERIC amd64 kernel.

  The installation is simple; two fully encrypted HDD (geom-eli) and a boot flash.  The flash starts the system, mounts the encrypted root and the process continues.

  The bootup sequence starts as usual; initializes all devices and asks for the encrypted root device password.  Once entered, the boot process continues but the screen output gets spaces like if the enter key was pressed.

  Login prompt then comes and, again like if the enter key was pressed, the login just repeats forever.

  I tried disabling the atkbd without success and disconnecting the usb keyboard does not stop the screen from scrolling.

  I also tried to boot the install disk with geom_eli loaded to mount the encrypted partition.  The kernel asks for password and continues with lines inserted again as if the enter key was pressed.  The sysinstall then starts and switches from the main menu to info and back (forever).

  Something is keeping the last key entered from the keyboard and repreats it to infinity....
Boot to an encrypted geom_eli partition using USB keyboard on a GENERIC amd64 kernel.


More information about the freebsd-bugs mailing list