misc/134792: problems installing and booting on MSI Master2-FAR (MS-9130)

Marshal Newrock marshal at freedombi.com
Thu May 21 18:20:02 UTC 2009

>Number:         134792
>Category:       misc
>Synopsis:       problems installing and booting on MSI Master2-FAR (MS-9130)
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu May 21 18:20:01 UTC 2009
>Originator:     Marshal Newrock
>Release:        7.1 i386, 7.2 AMD64
I believe the following to be a hardware or BIOS bug.  The motherboard mentioned is a dual opteron board.  Board info at http://us.msi.com/product/p_spec.asp?model=K8T_Master2_FAR&class=mb

I was trying to install FreeBSD on a machine with the above motherboard, 4GB of ECC DDR/400 (due to BIOS limits, the motherboard only recognizes 3.5GB), and a 160GB hard drive.  The installation went fine.  However, after reboot, the computer would not recognize the installation.  It just said "non system disk" and wouldn't boot.  After one such attempt, I booted off a Linux CD, which saw a previous partition table.  I ran badblocks on the drives to test and wipe them, but this did not change the results of installing FreeBSD.  This was with 7.2 AMD64 first, and then 7.1 i386.

Next, I tried updating the BIOS from v1.1 to v1.4 (nothing available in between).  On the next boot (with both install cd's), it took a while for the kernel to determine its boot parameters.  When it started to boot up, it soon got "AP #1 (PHY#1) panic", even in safe mode.  I believe this was when it was trying to load the APIC tables.  Physically removing one of the CPU's allowed it to boot, but I did not try installing at this point.

I have no other plans for this motherboard, so it is available for testing if needed.  Actually, I have two of them, and the above problems showed up on both.



More information about the freebsd-bugs mailing list