kern/133144: [linux] linuxulator 2.6 crashes with nvidias libGL.so.1

barbara barbara.xxx1975 at libero.it
Sun May 10 22:40:03 UTC 2009


The following reply was made to PR kern/133144; it has been noted by GNATS.

From: "barbara" <barbara.xxx1975 at libero.it>
To: "bug-followup" <bug-followup at FreeBSD.org>
Cc: "alexbestms" <alexbestms at math.uni-muenster.de>
Subject: Re: kern/133144: [linux] linuxulator 2.6 crashes with nvidias libGL.so.1
Date: Mon, 11 May 2009 00:30:25 +0200

 I have the same problem here.
 It was working on 6-STABLE and 7-STABLE using linux_base-fc4 and compat.l=
 inux.osrelease: 2.4.2.
 It never worked on 7-STABLE with linux_base-fc6/linux_base-f8 and compat.=
 linux.osrelease: 2.6.16.
 And the same setup it's not working on 8-CURRENT too.
 
 I've tried with linux-enemyterritory but I'm getting:
     ...loading libGL.so.1: Received signal 11, exiting...
     Segmentation fault: 11
 
 On dmesg I'm getting the following 2 lines:
     pid 26151 (et.x86), uid 1001: exited on signal 11
     linux_sys_futex: unknown op 800164673
 
 
 As the original OP said, it's working using libGL.so.1 from linux-f8-dri,=
  but with very bad performance.
 
 
 $ uname -a
 FreeBSD satanasso.local.net 8.0-CURRENT FreeBSD 8.0-CURRENT #0: Sun May 1=
 0 16:18:47 CEST 2009     root at satanasso.local.net:/usr/obj/usr/src/sys/SA=
 TANASSO  i386
 
 $ pkg_info -Ix linux nvidia
 linux-enemyterritory-2.60b Wolfenstein: Enemy Territory (Linux version)
 linux-f8-dri-7.0.2  Mesa libGL runtime libraries and DRI drivers (Linux F=
 edora 
 linux-f8-expat-2.0.1 Linux/i386 binary port of Expat XML-parsing library =
 (Linux 
 linux-f8-fontconfig-2.4.2 An XML-based font configuration API for X Windo=
 ws (Linux Fe
 linux-f8-xorg-libs-7.3_2 Xorg libraries (Linux Fedora 8)
 linux_base-f8-8_11  Base set of packages needed in Linux mode (for i386/a=
 md64)
 nvidia-driver-180.44 NVidia graphics card binary drivers for hardware Ope=
 nGL ren
 
 $ sysctl -a compat
 compat.linux.oss_version: 198144
 compat.linux.osrelease: 2.6.16
 compat.linux.osname: Linux
 
 


More information about the freebsd-bugs mailing list