possible bug with base install of bind on Freebsd 7.2-RELEASe

Dan Corrigan dancorrigan1 at gmail.com
Fri May 8 17:18:48 UTC 2009

On one of my semi-production nameservers I just upgraded from 7.1-RELEASE-p4
to 7.2-RELEASE, I started noticing log entries in /var/log/messages

May  8 11:26:06 phishbox named[32909]: the working directory is not writable

I thought this may have been caused my some paranoid permission I set on the
After troubleshooting for a while, I tested on a test machine at work, whose
only task is to run a daily rsync to back up another machine.

This test machine was also upgraded from 7.1-RELEASE-p4 to 7.2-RELEASE.
Nothing has been touched in /etc/namedb  All I did was add the entry into
/etc/rc.conf to enable named, named_enable="YES"

I tried to start named and got the same error:
May  8 11:44:42 danfreebsd named[1090]: the working directory is not

I would gladly paste the config from either machine, but other than adding
one user and adding a cronjob to rsync, the test machine is completely

I tried searching the freebsd bugs archive list to see if this bug has
already been discussed, but I couldn't find it.
If this is the incorrect place to report this, I apologize.


More information about the freebsd-bugs mailing list