kern/142009: [acpi] [panic] Panic in AcpiNsGetAttachedObject

Scot Hetzel swhetzel at gmail.com
Fri Dec 25 10:40:05 UTC 2009


>Number:         142009
>Category:       kern
>Synopsis:       [acpi] [panic] Panic in AcpiNsGetAttachedObject
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri Dec 25 10:40:04 UTC 2009
>Closed-Date:
>Last-Modified:
>Originator:     Scot Hetzel
>Release:        8-Stable
>Organization:
>Environment:
FreeBSD dv8t01 8.0-STABLE FreeBSD 8.0-STABLE #1 r200931M: Thu Dec 24 00:55:43 CST 2009     root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC  amd64

>Description:
I had installed FreeBSD 8.0-RC3/amd64 on a new HP dv8t Laptop and then had been upgrading system to the latest stable every couple of days.  During the process of setting the system up,  I had added the following modules to /boot/loader.conf:

zfs_load="YES"
opensolaris_load="YES"
snd_hda_load="YES"
sound_load="YES"
coretemp_load="YES"
acpi_wmi_load="YES"
acpi_hp_load="YES"
acpi_video="YES"
zlib_load="YES"
crypto_load="YES"
smbus_load="YES"
ichsmb_load="YES"
sdhci_load="YES"

When the acpi_hp kernel module was loaded, I was able to disable/enable the bluetooth device on the system using a kernel built from sources using this revision or older:

FreeBSD 8.0-STABLE #18 r199983: Fri Dec 18 02:06:33 CST 2009
Dec 18 02:18:55 dv8t01 kernel: root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC amd64

But when I upgraded the kernel to this revision or newer the WiFi Button fails to respond:

FreeBSD 8.0-STABLE #17 r199987: Fri Dec 18 00:38:21 CST 2009
root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC amd64

The only change between these two revisions is the "MFC r199016: acpi: remove 'magic' ivar" commit:

http://svn.freebsd.org/viewvc/base?view=revision&revision=199984

Another problem is that when I update to this revision or newer:

FreeBSD 8.0-STABLE #9 r200330: Thu Dec 17 10:22:04 CST 2009
Dec 17 10:37:50 dv8t01 kernel: root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC amd64

After the system boots and the Login prompt is displayed I get these ACPI error messages repeating every few seconds:

Dec 17 10:38:57 dv8t01 kernel: ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d80) [EmbeddedControl] 20090521 evregion-430
Dec 17 10:38:57 dv8t01 kernel: ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
Dec 17 10:38:57 dv8t01 kernel: ACPI Error (psparse-0633): Method parse/execution failed [\_TZ_.TZ01._TMP] (Node 0xffffff0002a47100), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d80) [EmbeddedControl] 20090521 evregion-430
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.ACAD._PSR] (Node 0xffffff0002a3e8a0), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d80) [EmbeddedControl] 20090521 evregion-430
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.BAT0._STA] (Node 0xffffff0002a3e700), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (uteval-0329): Method execution failed [\_SB_.BAT0._STA] (Node 0xffffff0002a3e700), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d80) [EmbeddedControl] 20090521 evregion-430
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.BAT0._BST] (Node 0xffffff0002a3e6c0), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d80) [EmbeddedControl] 20090521 evregion-430
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.BAT0._STA] (Node 0xffffff0002a3e700), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (uteval-0329): Method execution failed [\_SB_.BAT0._STA] (Node 0xffffff0002a3e700), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d80) [EmbeddedControl] 20090521 evregion-430
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.BAT0._STA] (Node 0xffffff0002a3e700), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (uteval-0329): Method execution failed [\_SB_.BAT0._STA] (Node 0xffffff0002a3e700), AE_NOT_EXIST
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d80) [EmbeddedControl] 20090521 evregion-430
Dec 17 10:38:58 dv8t01 kernel: ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
Dec 17 10:38:58 dv8t01 kernel: ACPI Error (psparse-0633): Method parse/execution failed [\_SB_.BAT0._BST] (Node 0xffffff0002a3e6c0), AE_NOT_EXIST

But if I back down to this revision it stops:

FreeBSD 8.0-STABLE #8 r200329: Thu Dec 17 09:43:59 CST 2009
Dec 17 10:48:32 dv8t01 kernel: root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC amd64

The only change between  r200329 and r200330, is "MFC r199675: Provide tunables for some of the usb sysctls that affect boot behavior."

http://svn.freebsd.org/viewvc/base?view=revision&revision=200330

This change  only adds TUNEABLE_INT's to the USB code.

I update the system to the latest revision (r200675) and it still exhibits the problem where the WiFi button is not functioning and continuous reports of ACPI Error messages after displaying the Login prompt.  I reverted the r199984 change, and now the WiFi Button can be used to disable the Bluetooth device, and there are no longer any ACPI Error messages being displayed after the system shows the Login prompt:

http://svn.freebsd.org/viewvc/base?view=revision&revision=199984

FreeBSD dv8t01 8.0-STABLE FreeBSD 8.0-STABLE #20 r200675M: Fri Dec 18 12:44:06 CST 2009
root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC  amd64

I have since updated to svn r200931, and when I boot an unpatched version of the kernel I get the following panic:

cpu7: <ACPI CPU> on acpi0                                                                                    
coretemp7: <CPU On-Die Thermal Sensors> on cpu7                                                              
est7: <Enhanced SpeedStep Frequency Control> on cpu7                                                         
p4tcc7: <CPU Frequency Thermal Control> on cpu7                                                              
acpi_hp0: HP event GUID detected, installing event handler                                                   
acpi_ec0: <Embedded Controller: GPE 0x666e696c, GLK, ECDT> port 0x62,0x66 on acpi0

Fata trap 12: page fault while in kernal mode
cpuid = 0; apic id = 00
fault virtual address = 0x34
fault code            = supervisor read data, page not present
instruction pointer   = 0x20:0xffffffff801cac79
stack pointer         = 0x28:0xffffffff812bfa00
frame pointer         = 0x28:0xffffffff812bfa10
code segment          = base 0x0, limit 0xfffff, type 0x1b
                      = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags      = interrupt enabled, resume, IOPL = 0
current process       = 0 (swapper)
[thread pid 0 tid 100000 ]
stopped at      AcpiNsGetAttachedObject+0x9:     movq     (%rdi),%rdx
db> bt
tracing pid 0 tid 100000 0xffffffff80c282e0
AcpiNsGetAttachedObject() at AcpiNsGetAttachedObject+0x9
AcpiEvGetGpeEventInfo() at AcpiEvGetGpeEventInfo+0x75
AcpiInstallGpeHandler() at AcpiInstallGpeHandler+0x61
acpi_ec_attach() at acpi_ec_attach+0x274
device_attach() at device_attach+0x69
bus_generic_attach at bus_generic_attach+0x1a
device_attach() at device_attach+0x69
bus_generic_new_patch at bus_generic_new_patch+0xd6
bus_set_pass() at bus_set_pass+0x7a
configure() at configure+0xa
mi_start() at mi_start+0x59
btext() at btext+0x2c
db>

I reverted r199016 and the following kernel boots:

dv8t01# uname -a
FreeBSD dv8t01 8.0-STABLE FreeBSD 8.0-STABLE #1 r200931M: Thu Dec 24 00:55:43 CST 2009     root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC  amd64

dmesg output where unpatched kernel crashed:

cpu7: <ACPI CPU> on acpi0                                                                                    
coretemp7: <CPU On-Die Thermal Sensors> on cpu7                                                              
est7: <Enhanced SpeedStep Frequency Control> on cpu7                                                         
p4tcc7: <CPU Frequency Thermal Control> on cpu7                                                              
acpi_hp0: HP event GUID detected, installing event handler                                                   
acpi_ec0: <Embedded Controller: GPE 0x16> port 0x62,0x66 on acpi0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>

I have dumped the dsdt code from this system and when I try to compile it, I get 532 errors,  I attempted to patch the dsdt to fix some of the problems, but not sure I patched it correctly.

The files are available at:

http://www.mediafire.com/file/ztgmvi5i3r2//usr/src/asl9/swhetzel-dv8t.tgz

The swhetzel-dv8t.tgz files contains the original asl, dsl and dst files, and my attemp at patching.  As well the error messages produced when attempting to compile the dst files.

Note: I was having problems with the iasl compiler (FreeBSD 8.0) core dumping, and have installed the iasl compiler from FreeBSD 9-CURRENT.

>How-To-Repeat:
Install FreeBSD Release on a HP dv8t Laptop, then upgrade the kernel to the latest stable sources (i.e r200931) and reboot.
>Fix:
Unknown, below is the dmesg from booting a kernel with r199016 reverted.

Patch attached with submission follows:

Copyright (c) 1992-2009 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.0-STABLE #1 r200931M: Thu Dec 24 00:55:43 CST 2009
    root at dv8t01:/usr/obj/usr/src/8-stable/sys/GENERIC amd64
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM) i7 CPU       Q 820  @ 1.73GHz (1729.21-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x106e5  Stepping = 5
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  Features2=0x98e3fd<SSE3,DTES64,MON,DS_CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT>
  AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
  AMD Features2=0x1<LAHF>
  TSC: P-state invariant
real memory  = 8589934592 (8192 MB)
avail memory = 8236384256 (7854 MB)
ACPI APIC Table: <HPQOEM SLIC-MPC>
FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
FreeBSD/SMP: 1 package(s) x 4 core(s) x 2 SMT threads
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
 cpu2 (AP): APIC ID:  2
 cpu3 (AP): APIC ID:  3
 cpu4 (AP): APIC ID:  4
 cpu5 (AP): APIC ID:  5
 cpu6 (AP): APIC ID:  6
 cpu7 (AP): APIC ID:  7
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
cryptosoft0: <software crypto> on motherboard
acpi0: <HPQOEM SLIC-MPC> on motherboard
ACPI: Overriding _OS definition with "Linux"
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi_hp0: Couldn't find acpi_wmi device
device_attach: acpi_hp0 attach returned 22
acpi0: reservation of ff000000, 2f00000 (3) failed
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
acpi_hp0: Couldn't find acpi_wmi device
device_attach: acpi_hp0 attach returned 22
acpi_ec0: <Embedded Controller: GPE 0x16> port 0x62,0x66 on acpi0
ACPI Error (psargs-0464): [\\_PR_.CPU0._PPC] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0633): Method parse/execution failed [\\CPUT] (Node 0xffffff0002a46ae0), AE_NOT_FOUND
ACPI Error (psparse-0633): Method parse/execution failed [\\PSSC] (Node 0xffffff0002a46ac0), AE_NOT_FOUND
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.PCI0.LPCB.EC0_._REG] (Node 0xffffff0002a441e0), AE_NOT_FOUND
acpi_ec0: can't install address space handler for \\_SB_.PCI0.LPCB.EC0_ - AE_NOT_FOUND
ACPI Error (psargs-0464): [\\_PR_.CPU0._PPC] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0633): Method parse/execution failed [\\CPUT] (Node 0xffffff0002a46ae0), AE_NOT_FOUND
ACPI Error (psparse-0633): Method parse/execution failed [\\PSSC] (Node 0xffffff0002a46ac0), AE_NOT_FOUND
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.PCI0.LPCB.EC0_._REG] (Node 0xffffff0002a441e0), AE_NOT_FOUND
ACPI Exception: AE_NOT_FOUND, from region _REG, [EmbeddedControl] 20090521 evregion-631
device_attach: acpi_ec0 attach returned 6
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 900
acpi_button0: <Power Button> on acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button1: <Sleep Button> on acpi0
acpi_acad0: <AC Adapter> on acpi0
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
battery0: <ACPI Control Method Battery> on acpi0
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
ACPI Error (uteval-0329): Method execution failed [\\_SB_.BAT0._STA] (Node 0xffffff0002a3e6a0), AE_NOT_EXIST
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 3.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0x7000-0x707f mem 0xd2000000-0xd2ffffff,0xc0000000-0xcfffffff,0xd0000000-0xd1ffffff irq 16 at device 0.0 on pci1
acpi_video0: <ACPI video extension> on vgapci0
ACPI Error: No handler for Region [ERAM] (0xffffff0002a37d00) [EmbeddedControl] 20090521 evregion-430
ACPI Error: Region EmbeddedControl(3) has no handler 20090521 exfldio-382
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.PCI0.P0P2.VGA_.LCD_.SBCM] (Node 0xffffff0002a40880), AE_NOT_EXIST
ACPI Error (psparse-0633): Method parse/execution failed [\\_SB_.PCI0.P0P2.VGA_.LCD_._BCM] (Node 0xffffff0002a408e0), AE_NOT_EXIST
can't evaluate \\_SB_.PCI0.P0P2.VGA_.LCD_._BCM - AE_NOT_EXIST
hdac0: <NVidia (Unknown) High Definition Audio Controller> mem 0xd3000000-0xd3003fff irq 16 at device 0.1 on pci1
hdac0: HDA Driver Revision: 20091113_0138
hdac0: [ITHREAD]
pci0: <base peripheral> at device 8.0 (no driver attached)
pci0: <base peripheral> at device 8.1 (no driver attached)
pci0: <base peripheral> at device 8.2 (no driver attached)
pci0: <base peripheral> at device 8.3 (no driver attached)
pci0: <base peripheral> at device 16.0 (no driver attached)
pci0: <base peripheral> at device 16.1 (no driver attached)
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xdd105c00-0xdd105fff irq 16 at device 26.0 on pci0
ehci0: [ITHREAD]
usbus0: EHCI version 1.0
usbus0: <EHCI (generic) USB 2.0 controller> on ehci0
hdac1: <Intel PCH High Definition Audio Controller> mem 0xdd100000-0xdd103fff irq 22 at device 27.0 on pci0
hdac1: HDA Driver Revision: 20091113_0138
hdac1: [ITHREAD]
pcib2: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pci2: <network> at device 0.0 (no driver attached)
pcib3: <ACPI PCI-PCI bridge> at device 28.1 on pci0
pci3: <ACPI PCI bus> on pcib3
re0: <RealTek 8168/8168B/8168C/8168CP/8168D/8168DP/8111B/8111C/8111CP/8111DP PCIe Gigabit Ethernet> port 0x5000-0x50ff mem 0xd4104000-0xd4104fff,0xd4100000-0xd4103fff irq 17 at device 0.0 on pci3
re0: Using 1 MSI messages
re0: Chip rev. 0x28000000
re0: MAC rev. 0x00000000
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus0
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
re0: Ethernet address: 00:26:9e:63:2c:29
re0: [FILTER]
pcib4: <ACPI PCI-PCI bridge> at device 28.3 on pci0
pci4: <ACPI PCI bus> on pcib4
pci4: <multimedia> at device 0.0 (no driver attached)
pcib5: <ACPI PCI-PCI bridge> at device 28.4 on pci0
pci5: <ACPI PCI bus> on pcib5
fwohci0: <1394 Open Host Controller Interface> mem 0xd9100000-0xd91007ff,0xd9100d00-0xd9100d7f,0xd9100c80-0xd9100cff,0xd9100c00-0xd9100c7f irq 16 at device 0.0 on pci5
fwohci0: [ITHREAD]
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:24:1b:00:69:af:9d:01
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: fwphy_rddata:: 0x5 loop=100, retry=100
fwohci0: fwphy_rddata:: 0x2 loop=100, retry=100
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
dcons_crom0: <dcons configuration ROM> on firewire0
dcons_crom0: bus_addr 0xbf6cc000
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:24:1b:af:9d:01
fwe0: Ethernet address: 02:24:1b:af:9d:01
fwip0: <IP over FireWire> on firewire0
fwip0: Firewire address: 00:24:1b:00:69:af:9d:01 @ 0xfffe00000000, S400, maxrec 2048
fwohci0: Initiate bus reset
fwohci0: fwphy_rddata:: 0x1 loop=100, retry=100
fwohci0: fwphy_rddata:: 0x1 loop=100, retry=100
pci5: <base peripheral> at device 0.1 (no driver attached)
sdhci0: <JMicron JMB38X SD> mem 0xd9100a00-0xd9100aff irq 16 at device 0.2 on pci5
sdhci0: 1 slot(s) allocated
sdhci0: [ITHREAD]
pci5: <base peripheral> at device 0.3 (no driver attached)
pci5: <base peripheral> at device 0.4 (no driver attached)
pcib6: <ACPI PCI-PCI bridge> at device 28.7 on pci0
pci6: <ACPI PCI bus> on pcib6
ehci1: <EHCI (generic) USB 2.0 controller> mem 0xdd105800-0xdd105bff irq 21 at device 29.0 on pci0
ehci1: [ITHREAD]
usbus1: EHCI version 1.0
usbus1: <EHCI (generic) USB 2.0 controller> on ehci1
pcib7: <ACPI PCI-PCI bridge> at device 30.0 on pci0
ACPI Warning: \\_SB_.PCI0.P0P1._PRT: Return Package has no elements (empty) 20090521 nspredef-545
pci10: <ACPI PCI bus> on pcib7
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel AHCI controller> port 0x8048-0x804f,0x8054-0x8057,0x8040-0x8047,0x8050-0x8053,0x8020-0x803f mem 0xdd105000-0xdd1057ff irq 19 at device 31.2 on pci0
atapci0: [ITHREAD]
atapci0: AHCI v1.30 controller with 6 3Gbps ports, PM not supported
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ata4: <ATA channel 4> on atapci0
ata4: [ITHREAD]
ata5: <ATA channel 5> on atapci0
ata5: [ITHREAD]
ichsmb0: <Intel PCH SMBus controller> port 0x8000-0x801f mem 0xdd106000-0xdd1060ff irq 19 at device 31.3 on pci0
ichsmb0: [ITHREAD]
smbus0: <System Management Bus> on ichsmb0
pci0: <dasp> at device 31.6 (no driver attached)
acpi_wmi0: <ACPI-WMI mapping> on acpi0
pcib8: <ACPI Host-PCI bridge> on acpi0
pci255: <ACPI PCI bus> on pcib8
acpi_tz0: <Thermal Zone> on acpi0
acpi_tz0: _CRT value is absurd, ignored (-273.2C)
atrtc0: <AT realtime clock> port 0x70-0x77 irq 8 on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: [ITHREAD]
psm0: model IntelliMouse, device ID 3
cpu0: <ACPI CPU> on acpi0
coretemp0: <CPU On-Die Thermal Sensors> on cpu0
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
cpu1: <ACPI CPU> on acpi0
coretemp1: <CPU On-Die Thermal Sensors> on cpu1
est1: <Enhanced SpeedStep Frequency Control> on cpu1
p4tcc1: <CPU Frequency Thermal Control> on cpu1
cpu2: <ACPI CPU> on acpi0
coretemp2: <CPU On-Die Thermal Sensors> on cpu2
est2: <Enhanced SpeedStep Frequency Control> on cpu2
p4tcc2: <CPU Frequency Thermal Control> on cpu2
cpu3: <ACPI CPU> on acpi0
coretemp3: <CPU On-Die Thermal Sensors> on cpu3
est3: <Enhanced SpeedStep Frequency Control> on cpu3
p4tcc3: <CPU Frequency Thermal Control> on cpu3
cpu4: <ACPI CPU> on acpi0
coretemp4: <CPU On-Die Thermal Sensors> on cpu4
est4: <Enhanced SpeedStep Frequency Control> on cpu4
p4tcc4: <CPU Frequency Thermal Control> on cpu4
cpu5: <ACPI CPU> on acpi0
coretemp5: <CPU On-Die Thermal Sensors> on cpu5
est5: <Enhanced SpeedStep Frequency Control> on cpu5
p4tcc5: <CPU Frequency Thermal Control> on cpu5
cpu6: <ACPI CPU> on acpi0
coretemp6: <CPU On-Die Thermal Sensors> on cpu6
est6: <Enhanced SpeedStep Frequency Control> on cpu6
p4tcc6: <CPU Frequency Thermal Control> on cpu6
cpu7: <ACPI CPU> on acpi0
coretemp7: <CPU On-Die Thermal Sensors> on cpu7
est7: <Enhanced SpeedStep Frequency Control> on cpu7
p4tcc7: <CPU Frequency Thermal Control> on cpu7
acpi_hp0: HP event GUID detected, installing event handler
acpi_ec0: <Embedded Controller: GPE 0x16> port 0x62,0x66 on acpi0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: cannot reserve I/O port range
ZFS filesystem version 13
ZFS storage pool version 13
Timecounters tick every 1.000 msec
usbus0: 480Mbps High Speed USB v2.0
usbus1: 480Mbps High Speed USB v2.0
ad4: 476940MB <Seagate ST9500420AS 0003HPM1> at ata2-master UDMA100 SATA 3Gb/s
acpi_tz0: _CRT value is absurd, ignored (-273.2C)
ugen0.1: <Intel> at usbus0
uhub0: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus0
ugen1.1: <Intel> at usbus1
uhub1: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
acd0: DVDR <hp BDDVDRW CT10L/YC09> at ata3-master UDMA100 SATA 1.5Gb/s
ad8: 238475MB <WDC WD2500BEVS-22UST0 01.01A01> at ata4-master UDMA100 SATA 1.5Gb/s
hdac0: HDA Codec #0: NVidia (Unknown)
hdac0: HDA Codec #1: NVidia (Unknown)
hdac0: HDA Codec #2: NVidia (Unknown)
hdac0: HDA Codec #3: NVidia (Unknown)
pcm0: <HDA NVidia (Unknown) PCM #0 DisplayPort> at cad 0 nid 1 on hdac0
pcm1: <HDA NVidia (Unknown) PCM #0 DisplayPort> at cad 1 nid 1 on hdac0
pcm2: <HDA NVidia (Unknown) PCM #0 DisplayPort> at cad 2 nid 1 on hdac0
pcm3: <HDA NVidia (Unknown) PCM #0 DisplayPort> at cad 3 nid 1 on hdac0
hdac1: HDA Codec #0: IDT 92HD75BX
pcm4: <HDA IDT 92HD75BX PCM #0 Analog> at cad 0 nid 1 on hdac1
pcm5: <HDA IDT 92HD75BX PCM #1 Analog> at cad 0 nid 1 on hdac1
pcm6: <HDA IDT 92HD75BX PCM #2 Digital> at cad 0 nid 1 on hdac1
SMP: AP CPU #7 Launched!
SMP: AP CPU #3 Launched!
SMP: AP CPU #1 Launched!
SMP: AP CPU #2 Launched!
SMP: AP CPU #4 Launched!
SMP: AP CPU #6 Launched!
SMP: AP CPU #5 Launched!
uhub0: 3 ports with 3 removable, self powered
uhub1: 3 ports with 3 removable, self powered
ugen0.2: <vendor 0x8087> at usbus0
uhub2: <vendor 0x8087 product 0x0020, class 9/0, rev 2.00/0.00, addr 2> on usbus0
ugen1.2: <vendor 0x8087> at usbus1
uhub3: <vendor 0x8087 product 0x0020, class 9/0, rev 2.00/0.00, addr 2> on usbus1
uhub2: 6 ports with 6 removable, self powered
uhub3: 8 ports with 8 removable, self powered
ugen1.3: <vendor 0x138a> at usbus1
ugen1.4: <QCM> at usbus1
ugen1.5: <Broadcom Corp> at usbus1
Trying to mount root from zfs:zroot
re0: link state changed to UP


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list