kern/138171: FreeBSD hangs on boot on HP DL580 G5 system (16 cores, 64GB ram)

Daniel Austin me at dan.me.uk
Tue Aug 25 15:00:03 UTC 2009


>Number:         138171
>Category:       kern
>Synopsis:       FreeBSD hangs on boot on HP DL580 G5 system (16 cores, 64GB ram)
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Aug 25 15:00:02 UTC 2009
>Closed-Date:
>Last-Modified:
>Originator:     Daniel Austin
>Release:        7.2-RELEASE
>Organization:
>Environment:
see description
>Description:
I have listed this as 'kern' rather than i386/amd64 as it affects both platforms.

images: https://www.dan.me.uk/hp-dl580-g5/

When attempting to install FreeBSD on a HP DL580 G5, it hangs during the boot process (always at the same point).  I have tried both amd64 and i386 editions, and 7.2-RELEASE and 8-SNAP (22 Aug 2009).

Various editions of Windows Server install and run fine on this server - but I want it to run FreeBSD!

With reference to the pictures at the above url:

001-normal-boot-fail-after-vga0.png (7.2-RELEASE/amd64)
  This is the point at which it crashes (standard boot from install cd)

002-bios-system-info-page.png
  BIOS information screen with bios versions etc listed

003-verbose-smap-info.png (7.2-RELEASE/amd64)
  Verbose boot showing the SMAP information

004-verbose-failure.png (7.2-RELEASE/amd64)
  This is the point at which it crashes (install cd, option 5 verbose)

005-verbose-failure-i386.png (7.2-RELEASE/i386)
  This is the point at which it crashes (as above, but i386 edition cd)

006-verbose-failure-freebsd8.png (8-SNAP/amd64)
  Failure during boot from 8-SNAP cd, verbose mode (22 Aug 2009 snap)

The server hardware is as follows:

HP ProLiant DL580 G5
4 x Intel Quadcore Xeon 2.4GHz CPUs (16 cores total)
32 x 2GB memory (total 64GB)
2 x HP SmartArray P400 RAID controllers (256mb + 512mb cache)
16 x 146GB SAS disks (2 x 8disk RAID6)

I have managed to get the server to boot to the installer once, just after the firmware update process.  However, after entering the BIOS and rebooting, I can no longer get it to boot.

Even after attempting a reset of the BIOS to defaults, it still does not boot.
I have also booted from the backup ROM with no effect on the boot process.

I am a long time FreeBSD user, and from a technical background - I'm happy to try anything in feedback to this issue.  Just add to the PR/email me.
>How-To-Repeat:
Obtain HP DL580 G5, install all available firmware updates using maintenance CD from HP, use FreeBSD install disc.
>Fix:
None

>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list