kern/134079: "em0: Invalid MAC address" in FreeBSD-Current ( 8.0)

Asp Gao g.zhengming at gmail.com
Wed Apr 29 05:50:02 UTC 2009


>Number:         134079
>Category:       kern
>Synopsis:       "em0: Invalid MAC address" in FreeBSD-Current ( 8.0)
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Wed Apr 29 05:50:01 UTC 2009
>Closed-Date:
>Last-Modified:
>Originator:     Asp Gao
>Release:        FreeBSD 8.0-Current
>Organization:
UTi (China) Ltd
>Environment:
FreeBSD.GZM.com 8.0-CURRENT FreeBSD 8.0-CURRENT #2: Thu Apr 23 01:51:50 CST 2009 root at FreeBSD.GZM.com:/usr/obj/usr/src/sys/MYKERNEL i386
>Description:
when load the intel Pro/1000 ethernet card by using :
   kldload if_em.ko or kldload if_igb.ko
system raise issue : 
   em0:<Intel(R) PRO/1000 Network Connection 6.9.9> port 0x3000-0x301f mem 0xee000000-0xee01ffff irq 16 at device 0.0 on pci2
   em0: Using MSI interrupt
   em0: Invalid MAC address
   device_attach:em0 attach returned 5

Note: I am using IBM T60 Laptop, and I have no this issue when use FreeBSD 7.0 stable. it only raised when upgraded to FreeBSD-Current.
>How-To-Repeat:
Use IBM T60 Laptop, install FreeBSD 7.0 stable with default setup . upgrade system by resource code to Freebsd 8.0-CURRENT. rebuild world, kernel. and install kernel and world .after reboot system , I get this issue . 
>Fix:
Dont know how to fix it .

>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list