kern/127901:

Andrew A. Vasilyev andy at demos.su
Mon Oct 6 12:40:02 UTC 2008


>Number:         127901
>Category:       kern
>Synopsis:       
>Confidential:   yes
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Oct 06 12:40:01 UTC 2008
>Closed-Date:
>Last-Modified:
>Originator:     
>Release:        
>Organization:
>Environment:
>Description:
 Submitter-Id:  current-users
 Originator:    andy
 Confidential:  no <FreeBSD PRs are public data>
 Synopsis:      SCSI Regression: "inquiry data fails comparison at DV1 step"
 Severity:      serious
 Priority:      high
 Class:         sw-bug
 Release:       FreeBSD 7.1-PRERELEASE i386
 Environment:
 System: FreeBSD spiritus.demos.su 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #6: Wed Sep 17 23:53:59 MSD 2008 andy at spiritus.demos.su:/mnt/obj/usr/src/sys/SPIRITUS i386
 Copyright (c) 1992-2008 The FreeBSD Project.
 Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
 	The Regents of the University of California. All rights reserved.
 FreeBSD is a registered trademark of The FreeBSD Foundation.
 FreeBSD 7.1-PRERELEASE #6: Wed Sep 17 23:53:59 MSD 2008
     andy at spiritus.demos.su:/mnt/obj/usr/src/sys/SPIRITUS
 Timecounter "i8254" frequency 1193182 Hz quality 0
 CPU: Intel(R) Xeon(R) CPU           E5420  @ 2.50GHz (2506.24-MHz 686-class CPU)
   Origin = "GenuineIntel"  Id = 0x10676  Stepping = 6
   Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
   Features2=0xce3bd<SSE3,RSVD2,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,DCA,<b19>>
   AMD Features=0x20100000<NX,LM>
   AMD Features2=0x1<LAHF>
   Cores per package: 4
 real memory  = 3753902080 (3580 MB)
 avail memory = 3667906560 (3497 MB)
 ACPI APIC Table: <INTEL  S5000PAL>
 FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
  cpu0 (BSP): APIC ID:  0
  cpu1 (AP): APIC ID:  1
  cpu2 (AP): APIC ID:  2
  cpu3 (AP): APIC ID:  3
  cpu4 (AP): APIC ID:  4
  cpu5 (AP): APIC ID:  5
  cpu6 (AP): APIC ID:  6
  cpu7 (AP): APIC ID:  7
 ioapic0 <Version 2.0> irqs 0-23 on motherboard
 ioapic1 <Version 2.0> irqs 24-47 on motherboard
 lapic0: Forcing LINT1 to edge trigger
 kbd1 at kbdmux0
 acpi0: <INTEL S5000PAL> on motherboard
 acpi0: [ITHREAD]
 acpi0: Power Button (fixed)
 Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
 acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
 acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
 Timecounter "HPET" frequency 14318180 Hz quality 900
 acpi_button0: <Power Button> on acpi0
 pcib0: <ACPI Host-PCI bridge> port 0xca2,0xca3,0xcf8-0xcff on acpi0
 pci0: <ACPI PCI bus> on pcib0
 pcib1: <ACPI PCI-PCI bridge> at device 2.0 on pci0
 pci1: <ACPI PCI bus> on pcib1
 pcib2: <ACPI PCI-PCI bridge> irq 16 at device 0.0 on pci1
 pci2: <ACPI PCI bus> on pcib2
 pcib3: <ACPI PCI-PCI bridge> irq 16 at device 0.0 on pci2
 pci3: <ACPI PCI bus> on pcib3
 pcib4: <ACPI PCI-PCI bridge> at device 0.0 on pci3
 pci4: <ACPI PCI bus> on pcib4
 mpt0: <LSILogic SAS/SATA Adapter> port 0x4000-0x40ff mem 0xf8910000-0xf8913fff,0xf8900000-0xf890ffff irq 16 at device 8.0 on pci4
 mpt0: [ITHREAD]
 mpt0: MPI Version=1.5.13.0
 pcib5: <PCI-PCI bridge> at device 0.2 on pci3
 pci5: <PCI bus> on pcib5
 pcib6: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci2
 pci6: <ACPI PCI bus> on pcib6
 pcib7: <ACPI PCI-PCI bridge> irq 16 at device 2.0 on pci2
 pci7: <ACPI PCI bus> on pcib7
 em0: <Intel(R) PRO/1000 Network Connection 6.9.5> port 0x3020-0x303f mem 0xf8820000-0xf883ffff,0xf8400000-0xf87fffff irq 18 at device 0.0 on pci7
 em0: Using MSI interrupt
 em0: [FILTER]
 em0: Ethernet address: 00:15:17:77:66:a4
 em1: <Intel(R) PRO/1000 Network Connection 6.9.5> port 0x3000-0x301f mem 0xf8800000-0xf881ffff,0xf8000000-0xf83fffff irq 19 at device 0.1 on pci7
 em1: Using MSI interrupt
 em1: [FILTER]
 em1: Ethernet address: 00:15:17:77:66:a5
 pcib8: <ACPI PCI-PCI bridge> at device 0.3 on pci1
 pci8: <ACPI PCI bus> on pcib8
 pcib9: <PCI-PCI bridge> at device 3.0 on pci0
 pci9: <PCI bus> on pcib9
 pcib10: <ACPI PCI-PCI bridge> at device 4.0 on pci0
 pci10: <ACPI PCI bus> on pcib10
 pcib11: <ACPI PCI-PCI bridge> at device 5.0 on pci0
 pci11: <ACPI PCI bus> on pcib11
 pcib12: <ACPI PCI-PCI bridge> at device 6.0 on pci0
 pci12: <ACPI PCI bus> on pcib12
 pcib13: <PCI-PCI bridge> mem 0xf8d00000-0xf8d01fff irq 16 at device 0.0 on pci12
 pci13: <PCI bus> on pcib13
 ahd0: <Adaptec AIC7902 Ultra320 SCSI adapter> port 0x2400-0x24ff,0x2000-0x20ff mem 0xf8c00000-0xf8c01fff irq 16 at device 4.0 on pci13
 ahd0: [ITHREAD]
 aic7902: Ultra320 Wide Channel A, SCSI Id=7, PCI-X 101-133Mhz, 512 SCBs
 pcib14: <ACPI PCI-PCI bridge> at device 7.0 on pci0
 pci14: <ACPI PCI bus> on pcib14
 pci0: <base peripheral> at device 8.0 (no driver attached)
 uhci0: <Intel 631XESB/632XESB/3100 USB controller USB-1> port 0x5080-0x509f irq 23 at device 29.0 on pci0
 uhci0: [GIANT-LOCKED]
 uhci0: [ITHREAD]
 usb0: <Intel 631XESB/632XESB/3100 USB controller USB-1> on uhci0
 usb0: USB revision 1.0
 uhub0: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
 uhub0: 2 ports with 2 removable, self powered
 uhci1: <Intel 631XESB/632XESB/3100 USB controller USB-2> port 0x5060-0x507f irq 22 at device 29.1 on pci0
 uhci1: [GIANT-LOCKED]
 uhci1: [ITHREAD]
 usb1: <Intel 631XESB/632XESB/3100 USB controller USB-2> on uhci1
 usb1: USB revision 1.0
 uhub1: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
 uhub1: 2 ports with 2 removable, self powered
 uhci2: <Intel 631XESB/632XESB/3100 USB controller USB-3> port 0x5040-0x505f irq 23 at device 29.2 on pci0
 uhci2: [GIANT-LOCKED]
 uhci2: [ITHREAD]
 usb2: <Intel 631XESB/632XESB/3100 USB controller USB-3> on uhci2
 usb2: USB revision 1.0
 uhub2: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
 uhub2: 2 ports with 2 removable, self powered
 uhci3: <Intel 631XESB/632XESB/3100 USB controller USB-4> port 0x5020-0x503f irq 22 at device 29.3 on pci0
 uhci3: [GIANT-LOCKED]
 uhci3: [ITHREAD]
 usb3: <Intel 631XESB/632XESB/3100 USB controller USB-4> on uhci3
 usb3: USB revision 1.0
 uhub3: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
 uhub3: 2 ports with 2 removable, self powered
 ehci0: <Intel 63XXESB USB 2.0 controller> mem 0xf8e00400-0xf8e007ff irq 23 at device 29.7 on pci0
 ehci0: [GIANT-LOCKED]
 ehci0: [ITHREAD]
 usb4: EHCI version 1.0
 usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
 usb4: <Intel 63XXESB USB 2.0 controller> on ehci0
 usb4: USB revision 2.0
 uhub4: <Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb4
 uhub4: 8 ports with 8 removable, self powered
 umass0: <Intel(R) Multidevice, class 0/0, rev 2.00/0.01, addr 2> on uhub4
 umass1: <Intel(R) Multidevice, class 0/0, rev 2.00/0.01, addr 2> on uhub4
 umass2: <Intel(R) Multidevice, class 0/0, rev 2.00/0.01, addr 2> on uhub4
 umass3: <Intel(R) Multidevice, class 0/0, rev 2.00/0.01, addr 2> on uhub4
 ums0: <Intel(R) Multidevice, class 0/0, rev 2.00/0.01, addr 2> on uhub4
 ums0: X report 0x0022 not supported
 device_attach: ums0 attach returned 6
 pcib15: <ACPI PCI-PCI bridge> at device 30.0 on pci0
 pci15: <ACPI PCI bus> on pcib15
 vgapci0: <VGA-compatible display> port 0x1000-0x10ff mem 0xf0000000-0xf7ffffff,0xf8b00000-0xf8b0ffff irq 17 at device 12.0 on pci15
 isab0: <PCI-ISA bridge> at device 31.0 on pci0
 isa0: <ISA bus> on isab0
 atapci0: <Intel 63XXESB2 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x50b0-0x50bf irq 20 at device 31.1 on pci0
 ata0: <ATA channel 0> on atapci0
 ata0: [ITHREAD]
 ata1: <ATA channel 1> on atapci0
 ata1: [ITHREAD]
 atapci1: <Intel 63XXESB2 SATA300 controller> port 0x50c8-0x50cf,0x50e4-0x50e7,0x50c0-0x50c7,0x50e0-0x50e3,0x50a0-0x50af mem 0xf8e00000-0xf8e003ff irq 20 at device 31.2 on pci0
 atapci1: [ITHREAD]
 ata2: <ATA channel 0> on atapci1
 ata2: [ITHREAD]
 ata3: <ATA channel 1> on atapci1
 ata3: [ITHREAD]
 ichsmb0: <Intel 631xESB/6321ESB (ESB2) SMBus controller> port 0x5000-0x501f irq 20 at device 31.3 on pci0
 ichsmb0: [GIANT-LOCKED]
 ichsmb0: [ITHREAD]
 smbus0: <System Management Bus> on ichsmb0
 smb0: <SMBus generic I/O> on smbus0
 sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
 sio0: type 16550A
 sio0: [FILTER]
 sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
 sio1: type 16550A
 sio1: [FILTER]
 atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
 atkbd0: <AT Keyboard> irq 1 on atkbdc0
 kbd0 at atkbd0
 atkbd0: [GIANT-LOCKED]
 atkbd0: [ITHREAD]
 cpu0: <ACPI CPU> on acpi0
 device_attach: acpi_perf0 attach returned 6
 device_attach: acpi_perf0 attach returned 6
 est0: failed to enable SpeedStep
 p4tcc0: <CPU Frequency Thermal Control> on cpu0
 cpu1: <ACPI CPU> on acpi0
 device_attach: acpi_perf1 attach returned 6
 device_attach: acpi_perf1 attach returned 6
 est1: failed to enable SpeedStep
 p4tcc1: <CPU Frequency Thermal Control> on cpu1
 cpu2: <ACPI CPU> on acpi0
 device_attach: acpi_perf2 attach returned 6
 device_attach: acpi_perf2 attach returned 6
 est2: failed to enable SpeedStep
 p4tcc2: <CPU Frequency Thermal Control> on cpu2
 cpu3: <ACPI CPU> on acpi0
 device_attach: acpi_perf3 attach returned 6
 device_attach: acpi_perf3 attach returned 6
 est3: failed to enable SpeedStep
 p4tcc3: <CPU Frequency Thermal Control> on cpu3
 cpu4: <ACPI CPU> on acpi0
 device_attach: acpi_perf4 attach returned 6
 device_attach: acpi_perf4 attach returned 6
 est4: failed to enable SpeedStep
 p4tcc4: <CPU Frequency Thermal Control> on cpu4
 cpu5: <ACPI CPU> on acpi0
 device_attach: acpi_perf5 attach returned 6
 device_attach: acpi_perf5 attach returned 6
 est5: failed to enable SpeedStep
 p4tcc5: <CPU Frequency Thermal Control> on cpu5
 cpu6: <ACPI CPU> on acpi0
 device_attach: acpi_perf6 attach returned 6
 device_attach: acpi_perf6 attach returned 6
 est6: failed to enable SpeedStep
 p4tcc6: <CPU Frequency Thermal Control> on cpu6
 cpu7: <ACPI CPU> on acpi0
 device_attach: acpi_perf7 attach returned 6
 device_attach: acpi_perf7 attach returned 6
 est7: failed to enable SpeedStep
 p4tcc7: <CPU Frequency Thermal Control> on cpu7
 orm0: <ISA Option ROM> at iomem 0xc0000-0xc8fff pnpid ORM0000 on isa0
 ppc0: parallel port not found.
 sc0: <System console> at flags 0x100 on isa0
 sc0: VGA <16 virtual consoles, flags=0x300>
 vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
 Timecounters tick every 1.000 msec
 ipfw2 initialized, divert enabled, nat loadable, rule-based forwarding enabled, default to accept, logging disabled
 acd0: DVDROM <DV-28E-V/1.AC> at ata0-slave UDMA33
 Waiting 3 seconds for SCSI devices to settle
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 ses0 at mpt0 bus 0 target 9 lun 0
 ses0: <ESG-SHV. SCA HSBP M11.... 1.41> Fixed Enclosure Services SCSI-3 device 
 ses0: 300.000MB/s transfers
 ses0: SCSI-3 SES Device
 da0 at mpt0 bus 0 target 1 lun 0
 da0: <FUJITSU MBA3073RC 0103> Fixed Direct Access SCSI-5 device 
 da0: 300.000MB/s transfers
 da0: Command Queueing Enabled
 da0: 70136MB (143638992 512 byte sectors: 255H 63S/T 8941C)
 da1 at mpt0 bus 0 target 2 lun 0
 da1: <FUJITSU MBA3073RC 0103> Fixed Direct Access SCSI-5 device 
 da1: 300.000MB/s transfers
 da1: Command Queueing Enabled
 da1: 70136MB (143638992 512 byte sectors: 255H 63S/T 8941C)
 da2 at mpt0 bus 0 target 3 lun 0
 da2: <SEAGATE ST373455SS S515> Fixed Direct Access SCSI-5 device 
 da2: 300.000MB/s transfers
 da2: Command Queueing Enabled
 da2: 70007MB (143374650 512 byte sectors: 255H 63S/T 8924C)
 da3 at mpt0 bus 0 target 4 lun 0
 da3: <ATA ST3320620AS K> Fixed Direct Access SCSI-5 device 
 da3: 300.000MB/s transfers
 da3: Command Queueing Enabled
 da3: 305245MB (625142448 512 byte sectors: 255H 63S/T 38913C)
 da5 at ahd0 bus 0 target 5 lun 0
 da5: <IFT IFT-7200 0145> Fixed Direct Access SCSI-4 device 
 da5: 6.600MB/s transfers (16bit)
 da5: Command Queueing Enabled
 da5: 457883MB (937744896 512 byte sectors: 255H 63S/T 58371C)
 cd0 at umass-sim0 bus 0 target 0 lun 0
 cd0: <Intel(R) RMM2 VDrive 1 0.01> Removable CD-ROM SCSI-3 device 
 cd0: 40.000MB/s transfers
 cd0: Attempt to query device size failed: NOT READY, Medium not present
 cd1 at umass-sim1 bus 1 target 0 lun 0
 cd1: <Intel(R) RMM2 VDrive 2 0.01> Removable CD-ROM SCSI-3 device 
 cd1: 40.000MB/s transfers
 cd1: Attempt to query device size failed: NOT READY, Medium not present
 cd2 at umass-sim2 bus 2 target 0 lun 0
 cd2: <Intel(R) RMM2 VDrive 3 0.01> Removable CD-ROM SCSI-3 device 
 cd2: 40.000MB/s transfers
 cd2: Attempt to query device size failed: NOT READY, Medium not present
 cd3 at umass-sim3 bus 3 target 0 lun 0
 cd3: <Intel(R) RMM2 VDrive 4 0.01> Removable CD-ROM SCSI-3 device 
 cd3: 40.000MB/s transfers
 cd3: Attempt to query device size failed: NOT READY, Medium not present
 lapic1: Forcing LINT1 to edge trigger
 SMP: AP CPU #1 Launched!
 lapic2: Forcing LINT1 to edge trigger
 SMP: AP CPU #2 Launched!
 lapic3: Forcing LINT1 to edge trigger
 SMP: AP CPU #3 Launched!
 lapic4: Forcing LINT1 to edge trigger
 SMP: AP CPU #4 Launched!
 lapic7: Forcing LINT1 to edge trigger
 SMP: AP CPU #7 Launched!
 lapic5: Forcing LINT1 to edge trigger
 SMP: AP CPU #5 Launched!
 lapic6: Forcing LINT1 to edge trigger
 SMP: AP CPU #6 Launched!
 Trying to mount root from ufs:/dev/da0s1a
 
 	<machine, os, target, libraries (multiple lines)>
 Description:
 
 ahd0: <Adaptec AIC7902 Ultra320 SCSI adapter> port 0x2400-0x24ff,0x2000-0x20ff mem 0xf8c00000-0xf8c01fff irq 16 at device 4.0 on pci13
 
 On boot:
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 (probe131:ahd0:0:5:0): inquiry data fails comparison at DV1 step
 
 External RAID failed to 6.600MB/s transfers (16bit),
 under FreeBSD 6.2-STABLE worked as SCSI-4 device at 160.000MB/s.
 
 	<precise description of the problem (multiple lines)>
 How-To-Repeat:
 Connect any external SCSI RAID to 7.1 box
 
>How-To-Repeat:
>Fix:

	


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list