misc/128683: CVS repo fails to check out because of permission denied error

Jamax codemonkey49 at earthlink.net
Mon Nov 10 10:20:04 PST 2008

The following reply was made to PR misc/128683; it has been noted by GNATS.

From: Jamax <codemonkey49 at earthlink.net>
To: Giorgos Keramidas <keramida at ceid.upatras.gr>
Cc: bug-followup at freebsd.org
Subject: Re: misc/128683: CVS repo fails to check out because of permission
 denied error
Date: Mon, 10 Nov 2008 13:03:08 -0500 (EST)

 Using newer cvs (on my linux workstation) adding -R says:
 cvs [checkout aborted]: Read-only repository feature unavailable with remote roots (cvsroot = freebsdanoncvs at anoncvs.FreeBSD.org:/home/ncvs)
 In freebsd 5.4 vmware image adding -R does not give an error, but the command does not appear to be doing anything.  I let it run for ~30 minutes.  Presumably this is collecting files on the server to transmit?  When I tried this before filing the bug it would error out after ~5 minutes; this difference could have been due to load on the server though and not the -R option.
 Anyway thanks to freebsdmadeeasy.com I found out how to use cvsup to do this:
 1) in /usr/share/examples/cvsup/stable-supfile change "tag=RELENG_5" to "tag=RELENG_5_4"
 2) cvsup -L2 -g -h cvsup.freebsd.org /usr/share/examples/cvsup/stable-supfile
 That worked fine, so I am all set.  The cvs checkout problem may still be there (I could not confirm that -R worked), but maybe it is more trouble to fix than it's worth.  It seems like downloading an entire cvs tarball would probably take less resources than doing the CVS checkout...
 Thanks for your help.  I thought cvs checkout would be the easiest way to get the updated sources, since I did not know how to write a cvsup file (and am behind firewall so was trying to avoid punching a hole for cvsup).
 -----Original Message-----
 >From: Giorgos Keramidas <keramida at ceid.upatras.gr>
 >Sent: Nov 7, 2008 8:52 PM
 >To: Code Monkey <codemonkey49 at earthlink.net>
 >Cc: bug-followup at freebsd.org
 >Subject: Re: misc/128683: CVS repo fails to check out because of permission denied error
 >On Fri, 7 Nov 2008 19:28:37 GMT, Code Monkey <codemonkey49 at earthlink.net> wrote:
 >> Running the following on my side:
 >> cvs -d freebsdanoncvs at anoncvs.FreeBSD.org:/home/ncvs checkout -r RELENG_5_4 src
 >> Error is:
 >> cvs [checkout aborted]: cannot write /home/ncvs/CVSROOT/val-tags: Permission denied
 >> Not a CVS expert but this sounds like a problem on the server, and it
 >> happens from linux client or freebsd.
 >Can you try checking out with the -R option?
 >    export CVSROOT='freebsdanoncvs at anoncvs.FreeBSD.org:/home/ncvs'
 >    cvs -R co -r RELENG_5_4 src
 >The -R option sets the client in `read only' mode, so that it can check
 >out from CD-ROMs and other read-only media.  I don't remember off the
 >top of my head if this works in `pserver' mode too, when the cvs(1)
 >utility tried to connect to remote servers, but it's worth trying.

More information about the freebsd-bugs mailing list