kern/116853: msk watchdog timeout

Kudo Chien ckchien at
Tue Oct 2 22:10:07 PDT 2007

>Number:         116853
>Category:       kern
>Synopsis:       msk watchdog timeout
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Wed Oct 03 05:10:07 GMT 2007
>Originator:     Kudo Chien
>Release:        7.0-CURRENT
FreeBSD mk12 7.0-CURRENT FreeBSD 7.0-CURRENT #0: Tue Oct  2 22:21:12 CST 2007     root at mk12:/usr/obj/usr/src/sys/GENERIC  i386

Whenever I try to get a FreeBSD iso file through ftp (transfer rate is about 3 MB/s), msk would be down. Some messages from dmesg are like:
msk0: watchdog timeout
msk0: link state changed to DOWN
msk0: link state changed to UP
mskc0: Tx descriptor error
mskc0: Tx descriptor error
msk0: watchdog timeout
msk0: link state changed to DOWN
msk0: link state changed to UP

I used FreeBSD 6.2-STABLE before, since there is some related patch for msk at FreeBSD-Current (if_msk.c rev. 1.18). I upgrade to Current, but the problem seems not solved. Certainly, I tried to add hw.msk.legacy_intr="1" in /boot/loader.conf. Whether disabling  MSI or not, the problem is as before. In order to avoid shared interrupt, I've also disabled USB device in BIOS, but not help.

Could you please tell me how to solve this problem.
Thanks a lot

My host is Intel Core 2 Duo E6300 + Onboard Marvel 8056 Gigabit LAN Controller (My MB is GA-965G-DS3 of Gigabyte,

msk0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:16:e6:de:bf:ed
        inet x.x.x.x netmask 0xffffff00 broadcast x.x.x.x
        media: Ethernet autoselect (1000baseTX <full-duplex,flag2>)
        status: active

boot message:
mskc0: <Marvell Yukon 88E8056 Gigabit Ethernet> port 0xa000-0xa0ff mem 0xf1000000-0xf1003fff irq 16 at device 0.0 on pci3
msk0: <Marvell Technology Group Ltd. Yukon EC Ultra Id 0xb4 Rev 0x02> on mskc0
msk0: Ethernet address: 00:16:e6:de:bf:ed
miibus0: <MII bus> on msk0
e1000phy0: <Marvell 88E1149 Gigabit PHY> PHY 0 on miibus0
e1000phy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX-FDX, auto
mskc0: [ITHREAD]

vmstat -i:
interrupt                          total       rate
irq1: atkbd0                           6          0
irq6: fdc0                             1          0
irq14: ata0                        97074          0
irq15: ata1                          629          0
irq16: mskc0                      288008          1
irq19: atapci0+                     1522          0
cpu0: timer                    421587304       1922
cpu1: timer                    421586922       1922
Total                          843561466       3846

pciconf -lv:
mskc0 at pci3:0:0: class=0x020000 card=0xe0001458 chip=0x436411ab rev=0x14 hdr=0x00
    vendor     = 'Marvell Semiconductor (Was: Galileo Technology Ltd)'
    class      = network
    subclass   = ethernet 
Get a FreeBSD iso file through ftp (transfer rate is about 3-4 MB/s), and msk would be down.


More information about the freebsd-bugs mailing list