boot2 can't boot from USB?

Oliver Fromme olli at
Thu Mar 15 11:45:56 UTC 2007

Fluffles <etc at> wrote:
 > Sorry if this is offtopic. Am i right to assume that:
 > - boot0 and boot1 both read from the disk via BIOS
 > - boot2 tries to read from the disk directly, without BIOS
 > ?

No, only the kernel contains drivers that are independent
from the BIOS.  Everything else (the boot* blocks and
/boot/loader) use BIOS calls.

 > If so, i may have found some bugs / problems with boot2. Long ago i
 > tried to make a bootable USB pendrive with FreeBSD 6.1 on it. It failed
 > to boot with the message "invalid slice" and i got a prompt like:
 > FreeBSD/i386 BOOT
 > Default: 0:ad(0,a)/boot/loader
 > boot:
 > Whatever i tried, it fails to load "Loader" or the kernel. Later, i
 > tried FreeNAS which enables the user to write an image to an USB
 > pendrive which contains a bootable FreeNAS installation. The copying
 > went ok, but i got the same boot problem. I then tried it on three
 > different systems with two different USB pendrives and they all had the
 > same problem. All of the systems supported USB boot, and it does
 > actually boot from USB how else could i see that FreeBSD boot prompt?
 > Some systems are brand new: dualcore SLI motherboards, etc.
 > It appears to me the boot2 program fails to read from USB. boot0 and
 > boot1 appear not to have this problem since it uses the BIOS to read
 > from the disk. Is this correct?

No, see above, they all use the BIOS.  The difference is
that boot2 needs to understand UFS, locate the correct
slice and partition with /boot/loader in it and load it.
The earlier boot blocks are relatively dumb and only know
how to load boot2 from a fixed location on the media.

So, if boot2 doesn't work for you, it's probably unable
to locate your FreeBSD slice and/or partition.  How did
you create them?

(Another difference is that boot2 enters protected mode
in order to be able to access memory above 1 MB, while
the earlier boot blocks use pure real mode.  But that
should not be related to the problem that you see.)

 > Are USB boot problems by boot2 known, should i file a PR?

boot2 doesn't know about USB at all.  It only knows about
BIOS-accessible drives (which may include USB drives if
that's enabled in the BIOS setup).

Best regards

Oliver Fromme, secnetix GmbH & Co. KG, Marktplatz 29, 85567 Grafing b. M.
Handelsregister: Registergericht Muenchen, HRA 74606,  Geschäftsfuehrung:
secnetix Verwaltungsgesellsch. mbH, Handelsregister: Registergericht Mün-
chen, HRB 125758,  Geschäftsführer: Maik Bachmann, Olaf Erb, Ralf Gebhart

FreeBSD-Dienstleistungen, -Produkte und mehr:

"With sufficient thrust, pigs fly just fine.  However, this
is not necessarily a good idea.  It is hard to be sure where
they are going to land, and it could be dangerous sitting
under them as they fly overhead." -- RFC 1925

More information about the freebsd-bugs mailing list