kern/100774: libthr + gdb + triggered breakpoint results in panic

Christoph Mallon christoph.mallon at gmx.de
Mon Jul 24 11:30:19 UTC 2006


>Number:         100774
>Category:       kern
>Synopsis:       libthr + gdb + triggered breakpoint results in panic
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Jul 24 11:30:12 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     Christoph Mallon
>Release:        RELENG_6
>Organization:
>Environment:
FreeBSD tron.homeunix.org 6.1-STABLE FreeBSD 6.1-STABLE #0: Tue May 16 20:05:33 CEST 2006     root at tron.homeunix.org:/usr/obj/usr/src/sys/KERNEL  i386

>Description:
I libmap'ed libpthread.so.2 to libthr.so.2, because the former gives problems in gdb when the debugged process raises SIGABRT. (gdb claims it can't find the process anymore, this seems to be same problem as reported in threads/80992)

I added a breakpoint and started the program I wanted to debug.
The breakpoint was reached - gdb showed the usual output for reaching a breakpoint. Directly after my system rebooted.
I tried this two more times with different breakpoints - same result.
This happend as non-privileged user debugging openttd. (see ports/games/openttd, though I used version from the svn repo and not the port)
It doesn't happen with libpthread. I couldn't test with libc_r, because gdb fails to fetch thread information.
I'm sorry, I have no further information about this. I don't know if it happens with other programs being debugged in gdb or what the output on /dev/console was, because the program I debugged was an X program.
>How-To-Repeat:
- use libthr
- debug (multithreaded) program in gdb
- set a breakpoint
- wait for breakpoint being reached -> system reboots
>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list