misc/101229: arping dependency issue

Adi ad1_x at yahoo.com
Tue Aug 1 23:20:15 UTC 2006

>Number:         101229
>Category:       misc
>Synopsis:       arping dependency issue
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Aug 01 23:20:14 GMT 2006
>Originator:     Adi
>Release:        6.1
FreeBSD neo 6.1-RELEASE FreeBSD 6.1-RELEASE #0: Sun Jul  9 22:55:50 EEST 2006     root at neo:/usr/src/sys/i386/compile/BSD  i386
The arping installation from source fails on current version of FreeBSD.
I think is a problem with libnet library, arping need an older version(<= but the current libnet version is

pkg_info | grep libnet
libnet-,1    A C library for creating IP packets

I tried an installation of the arping utility from binary package and installation works (pkg_add -r arping) but are some bugs in arping functionality (sometimes arping acts unusual, can't get reply )
I tried an installation from source but compilation failed:
===>   arping-2.05 depends on package: libnet*<=1.1.0,1 - not found
===>   Found libnet-,1, but you need to upgrade to libnet*<=1.1.0,1.
*** Error code 1

You cand repeat the problem if using FreeBSD-6.1 and and current version of arping and libnet. 


More information about the freebsd-bugs mailing list