bin/95956: 128-bit

Christopher Chin cchin at ack.Berkeley.EDU
Mon Apr 17 18:40:15 UTC 2006

>Number:         95956
>Category:       bin
>Synopsis:       128-bit
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Mon Apr 17 18:40:14 GMT 2006
>Originator:     Christopher Chin
>Release:        RELENG_6
UC Berkeley
FreeBSD bubble.Berkeley.EDU 6.1-RC FreeBSD 6.1-RC #1: Fri Apr 14 12:41:38 PDT 2006     cchin at bubble.Berkeley.EDU:/usr/obj/usr/src/sys/BUBBLE  i386

After a recent cvsup, buildworld, and new kernel, I can no longer 
effectively use 128bit wep with my wi0 driver.

This worked beautifully with my 5.4, and I'm pretty sure this worked
well after my upgrade to 6.0 and 6.1-PRERELEASE.

  bubble (cchin):/home/cchin# ifconfig wi0 wep wepkey 0x12345678901234567890abcdef 
  ifconfig: SIOCS80211: Invalid argument
  bubble (cchin):/home/cchin#

For reference, from 'dmesg':

  wi0: <Dell TrueMobile 1150 Series PC Card> at port 0xe000-0xe03f irq 9 function 0 config 1 on pccard2
  wi0: using Lucent Embedded WaveLAN/IEEE
  wi0: Lucent Firmware: Station (8.10.1)
  wi0: Ethernet address: 00:02:2d:6e:ad:46

'ifconfig wi0 wep wepkey 0x12345678901234567890abcdef'
'ifconfig wi0 wep wepkey 0x6162636465666768696A6B6C6D'
'ifconfig wi0 wep wepkey 0x6162636465666768696A6B6C6D00'


More information about the freebsd-bugs mailing list