kern/95729: [solved] Intel Pro/100 VE not detected on Toshiba A100-159

Nicky Bulthuis nicky.bulthuis at
Fri Apr 14 06:40:17 UTC 2006

>Number:         95729
>Category:       kern
>Synopsis:       [solved] Intel Pro/100 VE not detected on Toshiba A100-159
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Fri Apr 14 06:40:14 GMT 2006
>Originator:     Nicky Bulthuis
>Release:        FreeBSD 6.0-RELEASE
FreeBSD  6.0-RELEASE FreeBSD 6.0-RELEASE #1: Thu Apr 13 21:46:46 CEST 2006     root@:/usr/obj/usr/src/sys/GENERIC  i386

According to my googling and the FreeBSD documentation the Intel PRO/100 VE should be detected by the 'fxp' driver. Sadly it does not get detected on my new Toshiba A100-159 laptop. 

I've found several items on the Internet from people with the same problems (in 2003). Some provided a solution, i've used that solution and applied that to my Intel PRO/100 VE network card. The network card now works. 

output of 'pciconf -lv'

fxp0 at pci7:8:0:	class=0x020000 card=0xff101179 chip=0x10928086 rev=0x02 hdr=0x00
    vendor   = 'Intel Corporation'
    class    = network
    subclass = ethernet

This is after it was fixed, else the 'fxp0' would be 'none'. 

I'm running a new/default install of FreeBSD 6.0, GENERIC kernel. No extra options to either rc.conf, make.conf or any other configuration files. 


I hope i haven't forgotten anything, as this is my first problem report. I've also not have that much experience with patch/diff, so i'd like to leave that to someone with more experience. I could find no simliar problem reports or anything in the mailinglist archives, but perhaps i have missed it. 

Nicky Bulthuis

File changed: /sys/dev/fxp/if_fxp.c.

I've added the following line to this section : 

static struct fxp_ident fxp_ident_table[] = {

    { 0x1092,	-1,	"Intel Pro/100 VE Network Connection },

Once my network connection was up, i've cvsup'd to the latest of RELENG_6. As far as i could tell, the if_fxp.c file did not have the 0x1092 line for my network card. 


More information about the freebsd-bugs mailing list