ntpd bind error: address already in use

Mac Newbold mac at codegreene.com
Tue Nov 15 18:51:19 GMT 2005

We recently installed a new server running 5.4-STABLE and I noticed some 
ntpd errors in /var/log/messages:

Nov 15 10:42:22  ntpd[75492]: ntpd 4.2.0-a Sat Sep 24 16:57:36 UTC 2005 (1)
Nov 15 10:42:22  ntpd[75492]: bind() fd 7, family 2, port 123, addr, in_classd=0 flags=8 fails: Address already in use

After lots of googling I found many requests for help with similar issues, 
and eventually found the problem, and thought I'd share the solution.

The funny thing is I've got other boxes running 5.4-STABLE where ntpd 
works just fine. But I finally found the common thread between many of the 
people who reported this and my new server: multiple network cards. If 
you've got more than one interface, and one of them is unused, you can get 
these errors from ntpd. When I looked at my ifconfig, one of my interfaces 
was listed as inet because it is not in use. Just for kicks, I 
tried setting an IP address on it, even though it is down, and then I 
restarted ntpd. And it worked great. So now I've added an entry in my 
rc.conf to configure that interface with a static IP (one that doesn't get 
in the way) every time I reboot.

I hope this helps someone out there...


Mac Newbold			Code Greene, LLC
 				1440 S. Foothill Dr. Suite #250
Office:	801-438-0142		Salt Lake City, UT  84108
Cell:	801-694-6334		www.codegreene.com

More information about the freebsd-bugs mailing list