Suspected bug on FreeBSD 5.4 RAID problems on Fujitsu RX300 hardware

Nathan Butcher xqufa at
Mon May 23 04:45:36 GMT 2005

I'm having difficulties installing the recently released FreeBSD 5.4
onto a particular Fujitsu RX300 server. According to the start up BIOS
messages, these machines use an Adaptec I2O Raid Controller. Given what's happened, I think there's a bug in the RAID driver.

As the kernel loads up from the CD before the installation screens, the
kernel produces a Hard Disk related error a few times:-

ata1-master : FAILURE ATAPI_IDENTIFY timed out

This is a special case as I have had no problems booting up FreeBSD 5.4
on similar RX300 hardware with identical RAID and BIOS settings. The only
thing different between the booting and non-booting servers appears to
be the hard drives. Both machines have 3 hard drives, and RAID-1 has
been set up to use two of those drives (the third drive is a spare). The
RAID BIOS settings are identical on both machines with the exception
being the size of the hard drives between them.

Non working server:-
Capacity 137GB

Working server:-
Capacity 68GB

Also something interesting was noticed in the kernel messages (sorry, no
way to get an actual logfile of this) :-

Non working server:-
md0: Preloaded Image </boot/mfsroot> 4423680bytes at 0xc09dde24
ata1-master : FAILURE ATAPI_IDENTIFY timed out

Working server:-
md0: Preloaded Image </boot/mfsroot> 4423680bytes at 0xc09dde24
acd0: CDROM <SR244W/T02B> at ata1-master PIO 4

So what's really going on? Is the CD-ROM drive on the non-working server
hooked up the wrong way, or can't the RAID driver handle disk sizes that
are too big (bigger than 120GB maybe, like old PCI IDE cards)?
Could it be a bug?

As a side note, I have tried installing FreeBSD 4.11 on the server that won't boot 5.4, and it seems to work. Then I tried 5.3 on it, but that failed as well.

I'm going to see if changing the hard drives to something smaller helps.

More information about the freebsd-bugs mailing list