misc/81146: Sound isn't working AT ALL for Sis7012 onboard AC97 audio chipset with snd_ich

Luigi Lauro omero at m4d.it
Tue May 17 08:50:03 GMT 2005

>Number:         81146
>Category:       misc
>Synopsis:       Sound isn't working AT ALL for Sis7012 onboard AC97 audio chipset with snd_ich
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue May 17 08:50:02 GMT 2005
>Originator:     Luigi Lauro
>Release:        5.4
FreeBSD aspire1703 5.4-STABLE FreeBSD 5.4-STABLE #1: Mon May 16 17:01:16 CEST 2005     luigi.lauro at aspire1703:/usr/obj/usr/src/sys/ASPIRE1703  i386
On my 'Acer Aspire 1703SM' (info link: http://gerda.univie.ac.at/freebsd-laptops/index.pl?action=show_laptop_detail&laptop=640 ), even if devices are correctly compiled into kernel (sound & snd_ich), even if board is correctly detected and configured by driver, I get no sound at all, no matter what (tried a few program, even tried a cat 'long filename' > /dev/dsp to no avail), no matter where (even tried to plug headphones into mic or headphones port), no matter how (tried to play with some sysctl variables as vchans & others, also tried to pump up ALL mixer entries to 100:100, still no sound).

Sound part of my ASPIRE1703 kernel configuration file:
device          speaker
device          sound
device          snd_ich

dmesg output (trimmed):
pcm0: <SiS 7012> port 0x1800-0x187f,0x1c00-0x1cff irq 18 at device 2.7 on pci0
pcm0: <Avance Logic ALC202 AC97 Codec>

pciconf -lv output (trimmed):
pcm0 at pci0:2:7:  class=0x040100 card=0x00281025 chip=0x70121039 rev=0xa0 hdr=0x00
    vendor   = 'Silicon Integrated Systems (SiS)'
    device   = 'SiS7013 PCI Audio Accelerator'
    class    = multimedia
    subclass = audio

cat /dev/sndstat output:
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <SiS 7012> at io 0x1c00, 0x1800 irq 18 bufsz 16384  (1p/1r/32v channels duplex default)
Buy an Acer Aspire 1700 (any version will do, they all share the same motherboard, chipset & sound card), install any version of FreeBSD 5.x (tried 5.1, 5.2, 5.3, 5.4), kldload or compile-in devices (sound & snd_ich) and try to get sound.

You won't get any.
Wish I knew.

More information about the freebsd-bugs mailing list