kern/84930: something wrong with msdosfs on amd64

Mikhail T. mi at
Sun Aug 14 19:20:04 GMT 2005

>Number:         84930
>Category:       kern
>Synopsis:       something wrong with msdosfs on amd64
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sun Aug 14 19:20:02 GMT 2005
>Originator:     Mikhail Teterin
>Release:        FreeBSD 5.4-STABLE amd64
Virtual Estates, Inc.
System: FreeBSD 5.4-STABLE #7: Thu Jul 21 00:06:41 EDT 2005 ... amd64


	I just tried to move some songs over to the IRiver MP3-player.
	USB code recognized the device:

		da1 at umass-sim0 bus 0 target 0 lun 0
		da1: <TOSHIBA MK4004GAH JC00> Fixed Direct Access SCSI-0 device 
		da1: 1.000MB/s transfers
		da1: 38147MB (78126048 512 byte sectors: 255H 63S/T 4863C)

	and I was able to mount it:

	% mount -t msdosfs /dev/da1s1 /iriver

	The drive on it is just over half-full and df confirms it:

	/dev/da1s1         39052512 19902080 19150432    51%	/iriver

	Yet, when I tried to list the contents of the drive, I saw nothing:
		% ls -l /iriver
		total 0

	Another system -- i386 running 5.4-stable from April 23 -- had no
	problems and is busy copying the files as I type this.


	Try to write to an msdosfs on amd64.


More information about the freebsd-bugs mailing list