misc/73410: Sysinstall could not allocate disklabel

Emmanuel Brun d'Aubignosc eba at upsylon.com
Tue Nov 2 03:00:36 PST 2004

>Number:         73410
>Category:       misc
>Synopsis:       Sysinstall could not allocate disklabel
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Nov 02 11:00:32 GMT 2004
>Originator:     Emmanuel Brun d'Aubignosc
>Release:        5.3RC1
FreeBSD localhost.localdomain 5.3-RC1 FreeBSD 5.3-RC1 #0: Thu Oct 21 16:41:45 UTC 2004     root at localhost.localdomain:/usr/obj/usr/src/sys/MYKERNEL  i386
My ISP installed a new server for me with 2 200G hard drives. I asked him to partition each one into 2 100G slices and to do the disk labels for the 1st slice.

He wasn't able to allocate the last 20G. I tried to do it remote, but sysinstall's disklabel wouldn't work on the first disk. So I asked him to reboot the server on the install CD and retry. No luck, it just wouldn't work. The BIOS access mode is "auto".

I retried without sysinstall, using the comand "disklabel -e ad0s1". I created a new label manually, saved it, created a new file system, mounted it ... it all worked fine.

I really don't think that the ISP did anything wrong. He installed several smaller servers, for me, running freebsd 4.* without any problems. I had the same problem on another server running FreeBSD 5.2.1 at another ISP. 

When I searched "The freebsd-questions Archives", I found someone who has had the same problem with freebsd 5.2.1 

here us what disklabel gives me. I Added the G label manually

8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  a:  2097152  8752464    4.2BSD     2048 16384 28552
  b:  8228176   524288      swap
  c: 204796557        0    unused        0     0         # "raw" part, don't edit
  d: 10485760 10849616    4.2BSD     2048 16384 28552
  e: 10485760 21335376    4.2BSD     2048 16384 28552
  f: 161480704 31821136    4.2BSD     2048 16384 28552
  g: 11494717 193301840    4.2BSD     2048 16384 28552

Reinstall the system. I can't do that because the server is used in production.      
Use the command  "disklabel" from the command prompt.

More information about the freebsd-bugs mailing list