kern/69446: problems with SATA controller SIL 3112 and Western Digital HDD Raptor model 36GB

mystic mystic at
Thu Jul 22 12:10:21 PDT 2004

>Number:         69446
>Category:       kern
>Synopsis:       problems with SATA controller SIL 3112 and Western Digital HDD Raptor model 36GB
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Jul 22 19:10:21 GMT 2004
>Originator:     mystic
>Release:        FreeBSD 5.2.1-RELEASE
no "uname -a" available, unless I can't install the base system. FreeBSD 5.2.1-RELEASE ISO install-CD
When trying to install FreeBSD 5.2.1-RELEASE I get kernel panic, when copying files to the drive. Detection of hardware was successful and partitioning/formatting of partitions has been completed.
My hardware is: PCI SATA controller Sil 3112 and Western Digital Raptor 36GB hard drive. I used FreeBSD 5.2.1-RELEASE ISO image available on ftp.

The deadscreen:
cpuid = 0
syncing disks, buffer remaining... panic: bremfree:
removing a buffer not on a queue
cpuid = 0
uptime: 2m1s
kernel trap 12 with interrupts disabled

fatal trap 12 page fault while in kernel mode
cpuid = 0; apic id = 00
fault virtual adress    = 0x24
fault code              = supervisor read, page not present
instruction pointer     = 0x8:0xc065557e
stack pointer           = 0x10:0xcde83c2c
frame pointer           = 0x10:0xcde83c50
code segment            = base 0x0, imit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gran 1
processor eflags        = resume, IOPL = 0
current process         = 36(swi8: tty:sio clock)
trap number             = 12
panic: page fault
cpuid = 0
Uptime: 2m1s

I have got this problem every time, when I try to install FreeBSD 5.2.1-RELEASE on this disk drive. I also tried ACPI disabled and safe modes. It didn't bring any solution. The problem didn't occur on PATA drives, which I tried. I also couldn't install previous releases of FreeBSD 5.x on this SATA drive.

I don't know how to fix that problem. I hope it will be usefull for debugging.

More information about the freebsd-bugs mailing list