/dev/dsp problems @FreeBSD5.2.1 sndcard RTA3000

Kyryll A Mirnenko aka Mirya mirya at innovativemarketing.com.ua
Mon Aug 16 14:36:01 PDT 2004

got problems with sound using RTA3000 (Realtek) card:
1) card docs pray the card is SB16-compartible (in some way?)
2) pcm(4) worked for it fine on FreeBSD4.9 (kernel config attached)'
3) devices are listed in dmesg:

sbc0: <Avance Logic ALS120> at port 0x220-0x22f irq 5 drq 0,1 on isa0
pcm0: <SB16 DSP 4.153 (ViBRA16X)> on sbc0
midi0: <SB Midi Interface> on sbc0
midi1: <SB OPL FM Synthesizer> on sbc0
device_probe_and_attach: midi1 attach returned 6
midi2: <@H at 2001 Midi Interface> at port 0x388-0x38f on isa0
device_probe_and_attach: midi2 attach returned 6

4) doing something like `cat < garbage > /dev/dsp` produces noce as it should 
5) any of (amp|xmms) (prepackaged-4.9|prepackages-5.2.1|compiled from 
sources-5.2.1) doesn't work - hangs up
6) simple debugging amp with gdb shows it hangs up ao write() call in libc
7) kde-3.3.0rc1 arts says "can't open /dev/dsp" on startup

Can anybody handle it? Though it's could hand to reproduce the problem if it 
comes from soundcard I can do some debugging on my machine by I need some 
assistance of anybody who worked/working with this driver
Regards, Mirya
ICQ #313898202
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-bugs/attachments/20040817/02fb00df/attachment.bin
-------------- next part --------------

More information about the freebsd-bugs mailing list