kern/68351: bge0 watchdog timeout on 5.2.1 and -current, 5.1 is ok

Vadim Mikhailov freebsd-bugs at
Fri Aug 6 13:30:32 PDT 2004

The following reply was made to PR kern/68351; it has been noted by GNATS.

From: Vadim Mikhailov <freebsd-bugs at>
To: John Baldwin <jhb at>
Cc: freebsd-gnats-submit at
Subject: Re: kern/68351: bge0 watchdog timeout on 5.2.1 and -current, 5.1
 is ok
Date: Fri, 06 Aug 2004 13:22:00 -0700

 John Baldwin wrote:
 > On Friday 06 August 2004 03:10 pm, Vadim Mikhailov wrote:
 >>John Baldwin wrote:
 >>>On Friday 06 August 2004 02:02 pm, Vadim Mikhailov wrote:
 >>>>John Baldwin wrote:
 >>>>>Have you tried disabling ACPI to see if it works better?
 >>>>  Can not try it now - this is production server under load,
 >>>>and it is working fine since I installed Intel Pro/1000 XT card to
 >>>>overcome bge problems.
 >>>>  But, as stated in my original report, I did try it disabling ACPI
 >>>>about month ago with current - didn't make any difference.
 >>>>>Also, can you provide mptable output?
 >>>>  Here it is:
 >>>Thanks, can you also provide a full dmesg output?  The two bge's are
 >>>routed to pins 0 and 1 of the second I/O APIC which should be IRQs 16 and
 >>>17 if the first I/O APIC has 16 interrupt pins (dmesg will tell me that).
 >>   This is /var/run/dmesg.boot from verbose boot. Oddly enough, it does not
 >>start with standard FreeBSD copyrights, probably because of dmesg buffer
 >>overflow, however I didn't think this limit applies to /var/run/dmesg.boot
 >>file. Hopefully it still has enough information about APIC and interrupts.
 > Thanks.  It looks like the interrupts are routed just as both ACPI and the MP 
 > Table say they should be.  Have you tried using cvs to change the sys/dev/bge 
 > source back to 5.1 sources with the rest of the kernel being 5.2.1 to see if 
 > it works ok?
    Yes I did. Unfortunately difference between 5.1 and 5.2.1 is just too big:
    With 5.2.1-p9 sources when I replace if_bge.c rev. 1.60 (5_2_1_RELEASE) 
 with rev. 1.41 (5_1_0_RELEASE) kernel would not compile at all:
 /usr/src/sys/dev/bge/if_bge.c:107:24: pci/pcireg.h: No such file or directory
 /usr/src/sys/dev/bge/if_bge.c:108:24: pci/pcivar.h: No such file or directory
 mkdep: compile failed
 *** Error code 1
 Vadim Mikhailov

More information about the freebsd-bugs mailing list