kern/58353: Can't burn DVD media with Pioneer DVR-106 burner

Simun Mikecin sime at logos.hr
Tue Oct 21 14:30:11 PDT 2003


>Number:         58353
>Category:       kern
>Synopsis:       Can't burn DVD media with Pioneer DVR-106 burner
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue Oct 21 14:30:08 PDT 2003
>Closed-Date:
>Last-Modified:
>Originator:     Simun Mikecin
>Release:        FreeBSD 5.1-CURRENT i386
>Organization:
>Environment:
System: FreeBSD data.home.hr 5.1-CURRENT FreeBSD 5.1-CURRENT #0: Sun Oct 19 19:55:19 CEST 2003 root at data.home.hr:/usr/obj/usr/src/sys/DATA i386
	Using 5.1-CURRENT as of Oct 19 2003 on Pentium4 machine.
	Kernel compiled with SMP+APIC and atapicam.
	Hyperthreading logical processors disabled (default).
	This is dmesg output:

	Copyright (c) 1992-2003 The FreeBSD Project.
	Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
		The Regents of the University of California. All rights reserved.
	FreeBSD 5.1-CURRENT #0: Sun Oct 19 19:55:19 CEST 2003
	    root at data.home.hr:/usr/obj/usr/src/sys/DATA
	Preloaded elf kernel "/boot/kernel/kernel" at 0xc0842000.
	Preloaded elf module "/boot/kernel/agp.ko" at 0xc08421f4.
	Preloaded elf module "/boot/kernel/acpi.ko" at 0xc084229c.
	Timecounter "i8254" frequency 1193182 Hz quality 0
	CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2411.60-MHz 686-class CPU)
	  Origin = "GenuineIntel"  Id = 0xf29  Stepping = 9
	  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
	  Hyperthreading: 2 logical CPUs
	real memory  = 1073676288 (1023 MB)
	avail memory = 1033490432 (985 MB)
	Changing APIC ID for IO APIC #0 from 0 to 2 on chip
	Programming 24 pins in IOAPIC #0
	IOAPIC #0 intpin 2 -> irq 0
	FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
	 cpu0 (BSP): apic id:  0, version: 0x00050014, at 0xfee00000
	 cpu1 (AP):  apic id:  1, version: 0x00050014, at 0xfee00000
	 io0 (APIC): apic id:  2, version: 0x00178020, at 0xfec00000
	netsmb_dev: loaded
	Pentium Pro MTRR support enabled
	VESA: v3.0, 131072k memory, flags:0x1, mode table:0xc07563e2 (1000022)
	VESA: NVIDIA
	npx0: <math processor> on motherboard
	npx0: INT 16 interface
	acpi0: <GBT    AWRDACPI> on motherboard
	pcibios: BIOS version 2.10
	Using $PIR table, 15 entries at 0xc00fceb0
	acpi0: Power Button (fixed)
	Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
	acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
	acpi_cpu0: <CPU> on acpi0
	acpi_cpu1: <CPU> on acpi0
	acpi_button0: <Power Button> on acpi0
	pcib0: <ACPI Host-PCI bridge> port 0x1000-0x10bf,0xcf8-0xcff on acpi0
	pci0: <ACPI PCI bus> on pcib0
	IOAPIC #0 intpin 16 -> irq 2
	IOAPIC #0 intpin 19 -> irq 3
	IOAPIC #0 intpin 18 -> irq 9
	IOAPIC #0 intpin 23 -> irq 10
	IOAPIC #0 intpin 17 -> irq 11
	agp0: <Intel 82875P host to AGP bridge> mem 0xe0000000-0xe7ffffff at device 0.0 on pci0
	pcib1: <PCI-PCI bridge> at device 1.0 on pci0
	pci1: <PCI bus> on pcib1
	pci1: <display, VGA> at device 0.0 (no driver attached)
	pcib2: <ACPI PCI-PCI bridge> at device 3.0 on pci0
	pcib2: could not get PCI interrupt routing table for \\_SB_.PCI0.CSAB - AE_NOT_FOUND
	pci2: <ACPI PCI bus> on pcib2
	em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.16> port 0xb000-0xb01f mem 0xf4000000-0xf401ffff irq 9 at device 1.0 on pci2
	em0: [MPSAFE]
	em0:  Speed:N/A  Duplex:N/A
	uhci0: <Intel 82801EB (ICH5) USB controller USB-A> port 0xcc00-0xcc1f irq 2 at device 29.0 on pci0
	usb0: <Intel 82801EB (ICH5) USB controller USB-A> on uhci0
	usb0: USB revision 1.0
	uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
	uhub0: 2 ports with 2 removable, self powered
	uhci1: <Intel 82801EB (ICH5) USB controller USB-B> port 0xc000-0xc01f irq 3 at device 29.1 on pci0
	usb1: <Intel 82801EB (ICH5) USB controller USB-B> on uhci1
	usb1: USB revision 1.0
	uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
	uhub1: 2 ports with 2 removable, self powered
	uhci2: <Intel 82801EB (ICH5) USB controller USB-C> port 0xc400-0xc41f irq 9 at device 29.2 on pci0
	usb2: <Intel 82801EB (ICH5) USB controller USB-C> on uhci2
	usb2: USB revision 1.0
	uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
	uhub2: 2 ports with 2 removable, self powered
	uhci3: <Intel 82801EB (ICH5) USB controller USB-D> port 0xc800-0xc81f irq 2 at device 29.3 on pci0
	usb3: <Intel 82801EB (ICH5) USB controller USB-D> on uhci3
	usb3: USB revision 1.0
	uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
	uhub3: 2 ports with 2 removable, self powered
	ehci0: <EHCI (generic) USB 2.0 controller> mem 0xf4200000-0xf42003ff irq 10 at device 29.7 on pci0
	ehci_pci_attach: companion usb0
	ehci_pci_attach: companion usb1
	ehci_pci_attach: companion usb2
	ehci_pci_attach: companion usb3
	usb4: EHCI version 1.0
	usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
	usb4: <EHCI (generic) USB 2.0 controller> on ehci0
	usb4: USB revision 2.0
	uhub4: (0x8086) EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
	uhub4: 8 ports with 8 removable, self powered
	pcib3: <ACPI PCI-PCI bridge> at device 30.0 on pci0
	pci3: <ACPI PCI bus> on pcib3
	IOAPIC #0 intpin 21 -> irq 16
	IOAPIC #0 intpin 22 -> irq 17
	bktr0: <BrookTree 878> mem 0xf4100000-0xf4100fff irq 16 at device 1.0 on pci3
	bktr0: Hauppauge Model 44354 A321
	bktr0: Detected a MSP3415D-B3 at 0x80
	bktr0: Hauppauge WinCast/TV, Philips FR1216 PAL FM tuner, msp3400c stereo, remote control.
	pci3: <multimedia> at device 1.1 (no driver attached)
	pci3: <multimedia, audio> at device 2.0 (no driver attached)
	pci3: <input device> at device 2.1 (no driver attached)
	xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0x7800-0x787f mem 0xf3006000-0xf300607f irq 2 at device 3.0 on pci3
	xl0: Ethernet address: 00:01:02:55:db:f0
	miibus0: <MII bus> on xl0
	xlphy0: <3c905C 10/100 internal PHY> on miibus0
	xlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
	ahc0: <Adaptec 2940 Ultra2 SCSI adapter> port 0x7c00-0x7cff mem 0xf3004000-0xf3004fff irq 9 at device 4.0 on pci3
	aic7890/91: Ultra2 Wide Channel A, SCSI Id=7, 32/253 SCBs
	isab0: <PCI-ISA bridge> at device 31.0 on pci0
	isa0: <ISA bus> on isab0
	atapci0: <Intel ICH5 UDMA100 controller> port 0xf000-0xf00f,0-0x3,0-0x7,0-0x3,0-0x7 irq 2 at device 31.1 on pci0
	ata0: at 0x1f0 irq 14 on atapci0
	ata0: [MPSAFE]
	ata1: at 0x170 irq 15 on atapci0
	ata1: [MPSAFE]
	ichsmb0: <Intel 82801EB (ICH5) SMBus controller> port 0x1400-0x141f irq 11 at device 31.3 on pci0
	smbus0: <System Management Bus> on ichsmb0
	smb0: <SMBus generic I/O> on smbus0
	speaker0 port 0x61 on acpi0
	fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
	fdc0: FIFO enabled, 8 bytes threshold
	fd0: <1440-KB 3.5" drive> on fdc0 drive 0
	sio0 port 0x3f8-0x3ff irq 4 on acpi0
	sio0: type 16550A
	ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
	ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
	ppc0: FIFO with 16/16/16 bytes threshold
	ppbus0: <Parallel port bus> on ppc0
	lpt0: <Printer> on ppbus0
	lpt0: Interrupt-driven port
	ppi0: <Parallel I/O> on ppbus0
	atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
	atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
	kbd0 at atkbd0
	psm0: <PS/2 Mouse> irq 12 on atkbdc0
	psm0: model IntelliMouse Explorer, device ID 4
	pmtimer0 on isa0
	sc0: <System console> at flags 0x100 on isa0
	sc0: VGA <16 virtual consoles, flags=0x300>
	sio1: configured irq 3 not in bitmap of probed irqs 0
	sio1: port may not be enabled
	vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
	APIC_IO: Testing 8254 interrupt delivery
	APIC_IO: routing 8254 via IOAPIC #0 intpin 2
	
	Timecounters tick every 10.000 msec
	acpi_cpu: throttling enabled, 2 steps (100% to 50.0%), currently 100.0%
	GEOM: create disk ad0 dp=0xc6970970
	ad0: 176700MB <IC35L180AVV207-1> [359010/16/63] at ata0-master UDMA100
	acd0: DVDROM <Pioneer DVD-ROM ATAPIModel DVD-120S> at ata0-slave UDMA66
	(probe1:ata0:0:1:0): Recovered Sense
	(probe1:ata0:0:1:0): INQUIRY. CDB: 12 1 80 0 ff 0 
	(probe1:ata0:0:1:0): CAM Status: SCSI Status Error
	(probe1:ata0:0:1:0): SCSI Status: Check Condition
	(probe1:ata0:0:1:0): ILLEGAL REQUEST asc:24,0
	(probe1:ata0:0:1:0): Invalid field in CDB
	acd1: DVDR <PIONEER DVD-RW DVR-106D> at ata1-master UDMA33
	(probe18:ata0:0:1:0): Recovered Sense
	(probe18:ata0:0:1:0): INQUIRY. CDB: 12 1 80 0 ff 0 
	(probe18:ata0:0:1:0): CAM Status: SCSI Status Error
	(probe18:ata0:0:1:0): SCSI Status: Check Condition
	(probe18:ata0:0:1:0): ILLEGAL REQUEST asc:24,0
	(probe18:ata0:0:1:0): Invalid field in CDB
	(probe0:ata1:0:0:0): Recovered Sense
	(probe0:ata1:0:0:0): INQUIRY. CDB: 12 1 80 0 ff 0 
	(probe0:ata1:0:0:0): CAM Status: SCSI Status Error
	(probe0:ata1:0:0:0): SCSI Status: Check Condition
	(probe0:ata1:0:0:0): ILLEGAL REQUEST asc:24,0
	(probe0:ata1:0:0:0): Invalid field in CDB: Command byte 1 bit 0 is invalid
	(probe0:ata1:0:0:0): Recovered Sense
	(probe0:ata1:0:0:0): INQUIRY. CDB: 12 1 80 0 ff 0 
	(probe0:ata1:0:0:0): CAM Status: SCSI Status Error
	(probe0:ata1:0:0:0): SCSI Status: Check Condition
	(probe0:ata1:0:0:0): ILLEGAL REQUEST asc:24,0
	(probe0:ata1:0:0:0): Invalid field in CDB: Command byte 1 bit 0 is invalid
	GEOM: create disk cd0 dp=0xc6947600
	GEOM: create disk cd1 dp=0xc6946e00
	GEOM: create disk da0 dp=0xc696cc50
	da0 at ahc0 bus 0 target 6 lun 0
	da0: <QUANTUM ATLAS10K3_36_WLS 020W> Fixed Direct Access SCSI-3 device 
	da0: 80.000MB/s transfers (40.000MHz, offset 127, 16bit), Tagged Queueing Enabled
	da0: 35074MB (71833096 512 byte sectors: 255H 63S/T 4471C)
	SMP: AP CPU #1 Launched!
	(cd0:ata0:0:1:0): Recovered Sense
	(cd0:ata0:0:1:0): READ CD RECORDED CAPACITY. CDB: 25 0 0 0 0 0 0 0 0 0 
	(cd0:ata0:0:1:0): CAM Status: SCSI Status Error
	(cd0:ata0:0:1:0): SCSI Status: Check Condition
	(cd0:ata0:0:1:0): NOT READY asc:3a,0
	(cd0:ata0:0:1:0): Medium not present
	cd0 at ata0 bus 0 target 1 lun 0
	cd0: <PIONEER DVD-ROM DVD-120S 1.01> Removable CD-ROM SCSI-0 device 
	cd0: 66.000MB/s transfers
	cd0: Attempt to query device size failed: NOT READY, Medium not present
	(cd1:ata1:0:0:0): Recovered Sense
	(cd1:ata1:0:0:0): READ CD RECORDED CAPACITY. CDB: 25 0 0 0 0 0 0 0 0 0 
	(cd1:ata1:0:0:0): CAM Status: SCSI Status Error
	(cd1:ata1:0:0:0): SCSI Status: Check Condition
	(cd1:ata1:0:0:0): NOT READY asc:3a,0
	(cd1:ata1:0:0:0): Medium not present
	cd1 at ata1 bus 0 target 0 lun 0
	cd1: <PIONEER DVD-RW  DVR-106D 1.07> Removable CD-ROM SCSI-0 device 
	cd1: 33.000MB/s transfers
	cd1: Attempt to query device size failed: NOT READY, Medium not present
	(cd1:ata1:0:0:0): Recovered Sense
	(cd1:ata1:0:0:0): PREVENT ALLOW MEDIUM REMOVAL. CDB: 1e 0 0 0 1 0 
	(cd1:ata1:0:0:0): CAM Status: SCSI Status Error
	(cd1:ata1:0:0:0): SCSI Status: Check Condition
	(cd1:ata1:0:0:0): NOT READY asc:3a,0
	(cd1:ata1:0:0:0): Medium not present
	(cd1:ata1:0:0:0): Recovered Sense
	(cd1:ata1:0:0:0): PREVENT ALLOW MEDIUM REMOVAL. CDB: 1e 0 0 0 1 0 
	(cd1:ata1:0:0:0): CAM Status: SCSI Status Error
	(cd1:ata1:0:0:0): SCSI Status: Check Condition
	(cd1:ata1:0:0:0): NOT READY asc:3a,0
	(cd1:ata1:0:0:0): Medium not present
	Mounting root from ufs:/dev/ad0s1a
	pcm0: <Creative EMU10K1> port 0x7000-0x701f irq 17 at device 2.0 on pci3
	pcm0: <SigmaTel STAC9708/11 AC97 Codec>
	nvidia0: <GeForce4 Ti 4800 SE> mem 0xe8000000-0xefffffff,0xf0000000-0xf0ffffff irq 2 at device 0.0 on pci1
	WARNING: driver "rtc" used unreserved major device number 202
	WARNING: driver "vmmon" used unreserved major device number 200
	/dev/vmmon: Module vmmon: registered with major=200 minor=0 tag=$Name: build-570+ $
	/dev/vmmon: Module vmmon: initialized
	em0: promiscuous mode enabled
	vmnet1: promiscuous mode enabled
	Warning: pid 826 used static ldt allocation.
	See the i386_set_ldt man page for more info
	Warning: pid 982 used static ldt allocation.
	See the i386_set_ldt man page for more info
	em0: Link is up 100 Mbps Full Duplex
	em0: Link is Down
	em0: Link is up 100 Mbps Full Duplex
	Warning: pid 1032 used static ldt allocation.
	See the i386_set_ldt man page for more info
	Warning: pid 1144 used static ldt allocation.
	See the i386_set_ldt man page for more info

>Description:
	Burning DVD+RW media using sysutils/dvd+rw-tools port
	(dvd+rw-tools-5.12.4.7.4_1) ends successfully if I try to burn a
	file 1500 bytes long:

	# growisofs -Z /dev/cd1 -r -J small.txt
	WARNING: /dev/cd1 already carries isofs!
	About to execute 'mkisofs -r -J /etc/make.conf | builtin_dd of=/dev/pass2 obs=32k seek=0'
	Total translation table size: 0
	Total rockridge attributes bytes: 250
	Total directory bytes: 0
	Path table size(bytes): 10
	/dev/pass2: "Current Write Speed" is 2.4x1385KBps.
	Max brk space used e7c4
	48 extents written (0 Mb)
	/dev/pass2: flushing cache
	/dev/pass2: stopping de-icing
	/dev/pass2: writing lead-out

	But if I try a large file (180MB) it doesn't burn:
	# growisofs -Z /dev/cd1 -r -J large.dat
	WARNING: /dev/cd1 already carries isofs!
	About to execute 'mkisofs -r -J sol-8-u5-ia-v2.iso | builtin_dd of=/dev/pass2 obs=32k seek=0'
	/dev/pass2: "Current Write Speed" is 2.4x1385KBps.
	:-[ LBA=310h, SENSE KEY=Fh/ASC=FFh/ASCQ=FFh ]
	:-( write failed: Input/output error
	/dev/pass2: flushing cache
	/dev/pass2: stopping de-icing
	/dev/pass2: writing lead-out

	While doing that I get this in dmesg:

	(cd1:ata1:0:0:0): Recovered Sense
	(cd1:ata1:0:0:0): PREVENT ALLOW MEDIUM REMOVAL. CDB: 1e 0 0 0 1 0
	(cd1:ata1:0:0:0): CAM Status: SCSI Status Error
	(cd1:ata1:0:0:0): SCSI Status: Check Condition
	(cd1:ata1:0:0:0): UNIT ATTENTION asc:28,0
	(cd1:ata1:0:0:0): Not ready to ready change, medium may have changed

	DVD+RW Media that I'm burning is already fully formated:

	# dvd+rw-mediainfo /dev/cd1
	INQUIRY:                [PIONEER ][DVD-RW  DVR-106D][1.07]
	GET [CURRENT] CONFIGURATION:
	 Mounted Media:         1Ah, DVD+RW
	 Current Write Speed:   2.4x1385=3324KB/s
	 Write Speed #0:        2.4x1385=3324KB/s
	READ DVD STRUCTURE[#0h]:
	 Media Book Type:       92h, DVD+RW book [revision 2]
	 Legacy lead-out at:    2295104*2KB=4700372992
	READ DISC INFORMATION:
	 Disc status:           complete
	 Number of Sessions:    1
	 State of Last Session: complete
	 Number of Tracks:      1
	 BG Format Status:      complete
	READ TRACK INFORMATION[#1]:
	 Track State:           complete
	 Track Start Address:   0*2KB
	 Free Blocks:           0*2KB
	 Track Size:            2295104*2KB
	FABRICATED TOC:
	 Track#1  :             14 at 0
	 Track#AA :             14 at 2295104
	 Multi-session Info:    #1 at 0

	I haven't tried other types of DVD media (DVD-RW,DVD-R or DVD+R). 
	DVD+R and DVD-R media is too expensive to make a try, and I suspect
	it will not work as long as DVD+RW writing is not working.
	Burning DVD media with growisofs (sysutils/dvd+rwtools) worked
	before ATAng commit, so I conclude it's an ATAng bug, not a
	dvd+rw-tools bug.

>How-To-Repeat:
	try to burn DVD+RW media using growisofs (sysutils/dvd+rw-tools
	port)
>Fix:
	None that I know of.
>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list