bin/52469: ppp: Multiple devices using UDP don't work.

Olaf Erb olaf.erb at
Tue May 20 05:40:08 PDT 2003

>Number:         52469
>Category:       bin
>Synopsis:       ppp: Multiple devices using UDP don't work.
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Tue May 20 05:40:04 PDT 2003
>Originator:     Olaf Erb
>Release:        FreeBSD 4.8-STABLE i386
secnetix GmbH & Co. KG
System: FreeBSD schmutz 4.8-STABLE FreeBSD 4.8-STABLE #1: Fri May 16 19:47:09 CEST 2003 olaf at schmutz:/usr/src/sys/compile/schmutz i386

	If using multiple UDP devices with userland ppp only the 
        first host is tried forever.
	set device host1:5000/udp host2:5000/udp

	Try to dial then, if host1 is down, host2 is never tried. According to
        the manpage it should try all devices until a connection is 
        This works as expected using a real physical device or TCP, but not 
        with udp.
	none known.


More information about the freebsd-bugs mailing list