RPI3 swap experiments

bob prohaska fbsd at www.zefox.net
Wed Jun 27 19:42:05 UTC 2018

On Tue, Jun 26, 2018 at 11:30:52PM -0700, Mark Millard wrote:
> On 2018-Jun-26, at 10:40 PM, bob prohaska <fbsd at www.zefox.net> wrote:
[apologies to all, especially Mark, for the length of this tale. Keeping
it short, sweet and accurate is harder than expected!]

[big snip]
> A) Any examples of /dev/da0 errors without crashes?
No. /dev/da0 errors always end in a panic or hang.

> B) Any examples of crashes without /dev/da0 errors?
> C) All examples that do either also does the other
>    (so both always go together)?

Rarely, on hands-off reboot, da0 errors were reported, with
eventual panic, but fsck always cleared the problem. Later on it
seemed booting first to single user, then exiting to multiuser
fixed (or avoided) the problem. So, ephemeral /dev/da0 errors
have been seen without running -j4 buildworld. Next time it happens
I'll try to capture the messages. IIRC, they started with "lost mount".
Once the system goes multi-user no da0 errors have been seen apart
from those during -j4 buildworld.


> (I've having trouble parsing a specific meaning for
> the reference. I did not go back trough all the logs
> again to identify the combinations recorded.)
> For (A), have you tried any examples of:
> sufficient swap on mmcsd0 (or other such) with no swap
> on da0 (but /usr and /var on /dev/da0)?
Yes, that is the configuration which completes successfully.
> If yes, did you check on if there were /dev/da0 errors
> logged? What, if any, /dev/da0 errors where logged?
> None?
Correct, no errors on da0 when -j4 buildworld is successful.

> For (B), have you tried any examples of:
> insufficient swap on (say) mmcsd0 and no use of the
> /dev/da0 drive that has reported errors at all,
> /usr/ and /var not on mmcsd0 (or whatever was used
> for swap) either? Did some drive end up reporting
> errors? Which? Did the system still crash as well?
I think this is the standard test case:
/usr and /var on /dev/da0
/tmp on /dev/mmcsd0s3a
swap on /dev/mmcsd0s3b

This configuration has crashed reliably with errors on /dev/da0 but no other "disk" errors.
Did I understand the question correctly?
> Have such test-context combinations been tried?
> Without any logs to look at for such alternatives, I
> can not try to compare/contrast such to the others
> examples.

Understood. The matrix of test conditions is not completely filled,
and the test of different media for /dev/da0 has not yet been made.
I'd like to play with stress2 and ports/sysutils/stress before doing

There is a new, successful -j4 buildworld swapuse.log for the case
of 3 GB of USB flash swap at


The system is now up to r335655 and I'm trying to replicate 
earlier crash behavior before proceeding further. 

Thanks for reading!

bob prohaska

More information about the freebsd-arm mailing list