Current status of www/apache24

Spil Oss spil.oss at
Sun Feb 3 15:12:43 UTC 2013

Hi Corey,

Thanks for your effort! I've pulled to give it a run. Cross-posted
this to freebsd-ports as I have seen requests for Apache 2.4 on IRC
and it'll be helpful to those wanting Apache 2.4 before an official
port is released.

I've been testing the port you've created. It compiles fine with clang
3.1 on FreeBSD 9.1! I've run into a couple of snags though. Still,
I've almost got a running Apache 2.4 on FreeBSD! That is, I've been
able to serve some static files and php as a module works but I failed
when migrating the full config for all vhosts with all the features
that are used.
1. mod_watchdog
configure: WARNING: "mod_watchdog is disabled but required for mod_heartbeat"
I can't find an OPTION for heartbeat, so either watchdog shouldn't be
an option or heartbeat should?
Solved by enabling watchdog

2. /usr/local/bin/apxs
The port installs apxs to /usr/local/bin where apache22 installs it in
Other ports (lang/php5) expect apxs to be in /usr/local/sbin
Solved by hardlinking apxs in /usr/local/sbin for now...

3. mod_unixd
mod_unixd can't be disabled (not an option) or httpd won't start
[core:crit] [pid 33064:tid 679494400] AH00136: Server MUST relinquish
startup privileges before accepting connections.  Please ensure
mod_unixd or other system security module is loaded.
AH00016: Configuration Failed
Looks like unixd is required on Unix platforms and shouldn't be an option.
Solved by enabling UNIXD

4. mod_so
Should it be an option at all? I have it disabled yet I can load
modules and httpd -l reports that mod_so is built-in
Or is this option for building an external .so (which sounds a bit silly!)

5. mod_socache_shmdb
If SSL is enabled one socache module must be enabled for a functional SSL daemon
Some check for this in the Makefile would be helpful

6. mod_digest
[Fri Feb 01 23:39:08.202525 2013] [auth_digest:notice] [pid 73983:tid
679494400] AH01757: generating secret for digest authentication ...
[Fri Feb 01 23:39:08.202768 2013] [auth_digest:error] [pid 73983:tid
679494400] (78)Function not implemented: AH01762: Failed to create
shared memory segment on file /var/run/authdigest_shm.73983
[Fri Feb 01 23:39:08.202818 2013] [auth_digest:error] [pid 73983:tid
679494400] (78)Function not implemented: AH01760: failed to initialize
shm - all nonce-count checking, one-time nonces, and MD5-sess
algorithm disabled
[Fri Feb 01 23:39:08.202831 2013] [:emerg] [pid 73983:tid 679494400]
AH00020: Configuration Failed, exiting
Haven't figured this out at all yet.

7. MPM
Now I checked I see that I didn't have any MPM enabled in the options,
but this results in a default to worker-MPM. The port's
Makefile.modules claims otherwise.
IGNORE= At least one MPM must be selected.

I'll be trying to patch up the port and send you a patch (should be
possible with cloning etc as well, but I have no functional Git dev



More information about the freebsd-apache mailing list