Please mark apache13-ssl BROKEN

Chris H. chris# at
Mon Jan 28 15:07:55 PST 2008

Quoting "Chris H." <>:

> Greetings,
> After building the www/apache13-ssl from ports src, and installing
> without errors. I ran httpsdctl configtest to insure everything was
> AOK.
> However, it is not. It returns the following:
> Syntax error on line 208 of /usr/local/etc/apache/httpsd.conf:
> Cannot load /usr/local/libexec/apache/ into server: 
> /usr/local
> /libexec/apache/ Undefined symbol "ap_null_cleanup"
> Commenting the loadmodule line only causes Apache to complain about
> the next module in the same fashion. This is a terrible loss to the
> FreeBSD ports system. Any news as to when Apache will be working again?
> FYI:
> FreeBSD-7-PRERELEASE cvsupped src/ports 2008-01-15, build/install 
> world/kernel
> on the same day.
> This is an SMP system (2 CPU).
> Everything /but/ Apache works as expected.

OK. I found the problem with this. Seems inspite of the fact that
/usr/bin/objformat is considered obsolete, and is not created by
default. It /is/ needed - at least for www/apache13-ssl. So I was
able to build a working copy of Apache by performing the following:

touch /usr/bin/objformat

Edit /usr/bin/objformat and add the following:

echo elf

Save the file and perform the following:

chmod +r +x -w /usr/bin/objformat

Built www/apache13-ssl from src, and everything worked perfectly. :)

  Chris out...

> -- 
> panic: kernel trap (ignored)

panic: kernel trap (ignored)

More information about the freebsd-apache mailing list