php upgrading/version issue

Trakman at gmail.com trakman at gmail.com
Sat May 26 01:17:08 UTC 2007


ok, so I need to update my php:

php5-5.2.1_3                <  needs updating (port has 5.2.2)
php5-bz2-5.2.1_3            <  needs updating (port has 5.2.2)
php5-ctype-5.2.1_3          <  needs updating (port has 5.2.2)
.
.
.
php5-zlib-5.2.1_3           <  needs updating (port has 5.2.2)

this is what I do:

>portupgrade php5-5.2.1_3
>
>portupgrade php5-bz2-5.2.1_3
>
>portupgrade php5-ctype-5.2.1_3
>
.
.
.
and so on, till all are upgraded...

this is rather time consuming is there a quicker way to upgrade all of php
in one go?
am I meant to stop apache running before upgrading php?

after I upgrade my php this way, when I do a 'phpinfo' - it still shows the
previous php version, instead of the new version number.
am I meant to reinstall/re-make apache after upgrading php???

Thanks.


More information about the freebsd-apache mailing list