mmcache problem

Lorenzo Perone lopez.on.the.lists at
Sun Mar 20 05:54:24 PST 2005

Hi, I've had this problem before, actually with apache 1 and 2.

Did you verify if the the php session module (
is installed and loaded?

Have a look at
/usr/local/php/extensions.ini and make sure there is a
if not, you may have to install it depending on what you did
until now.

If you installed php via the port lang/php4, it might be just
enough to cd /usr/ports/www/php4-session and make install.
The module ports usually also add the extension= line in
/usr/local/php/extensions.ini. However, always verify that file,
as the ports tend to mess it up with multiple entries when you do

If you will use the extensions.ini to load mmcache,
also take care that its line has to be _before_'s.

It _may_ be possible to do without the session module, possibly with a
mmcache.sessions="0" or similar. I did not try this.

Also, consider trying eAccelerator 0.92a, which is the successor
of mmcache, particularly with php 4.3.10.
I've had some weird situations with mmcache and php 4.3.10.
I've not had the time yet to verify them thoroughly, but it seems to
me that php 4.3.10 exposes some bugs in mmcache that 4.3.9 did not
expose that roughly (apache core dumps), some of which seem to be
resolved in eaccelerator (at least for what i can see).

Hope this helps,


On 19.03.2005, at 21:42, ray at wrote:

> Hi List,
>   I'm having problems getting mmcache to work with Apache 1.3.33 &
> PHP4.3.10. I've tried building mmcache from source and also building it
> from /usr/ports/www
>   Get the following error message in my apache logs no matter what I
> do:
> /libexec/ /usr/local/lib/php/20020429/ Undefined
> symbol "php_session_register_module"
>   I've tried compiling apache with full module support, as well as
> stripped down with just mod_so support.  I've tried getting mmcache to
> work with PHP4 loaded as a DSO and also with PHP4 statically compiled
> into apache.  Still always the same error message.  I've tried
> everything I can think of.  I have tried loading directly
> via a LoadModule statement in httpd.conf as well as allowing PHP to
> load it via the PHP.INI file.  I get the error message above when I run
> PHP from the command line and also when Apache tries to run.
> My php.ini file has the following in it:
> [mmcache]
> zend_extension="/usr/local/lib/php/20020429/"
> mmcache.shm_size="16"
> mmcache.cache_dir="/tmp/mmcache"
> mmcache.enable="1"
> mmcache.optimizer="1"
> mmcache.check_mtime="1"
> mmcache.debug="0"
> mmcache.filter=""
> mmcache.shm_max="0"
> mmcache.shm_ttl="0"
> mmcache.shm_prune_period="0"
> mmcache.shm_only="0"
> mmcache.compress="1"
> mmcache.keys="shm_and_disk"
> mmcache.sessions="shm_and_disk"
> mmcache.content="shm_and_disk"
> I'm at a loss.  I can't seem to get it working.  The only information
> on the web I can find shows mmcache being installed no problem and I
> don't seem to be able to find much information regarding any of the
> error messages, etc.
> Does anyone have any ideas and/or has anyone gotten it to work with
> Apache 1.3.33 and PHP4.3.10 - either with PHP as a module or when
> statically compiled?
> Thanks!
> Ray
> _______________________________________________
> freebsd-apache at mailing list
> To unsubscribe, send any mail to
> "freebsd-apache-unsubscribe at"

More information about the freebsd-apache mailing list