ATAPI_IDENTIFY error while trying to install FreeBSD on Acer Veriton M421G

Elena Mihailescu elenamihailescu22 at
Mon Oct 2 13:19:11 UTC 2017


I am trying to install FreeBSD 12.0-CURRENT / FreeBSD 11.1-RELEASE on an
Acer Veriton M421G with AMD Athlon II X2 250 processor and M2N rev 1.02g

While booting from USB, it does not recognize the harddisk (a SATA HDD) and
I cannot continue the process of installation. I get the following error
periodically :

ahcich1: is 00000002 cs 00000000 ss 00000000 rs 00001000 tfd 50 serr
00000000 cmd 00046c17
(aprobe0:ahcich1:0:0:0): ATAPI_IDENTIFY. ACB: a1 00 00 00 00 40 00 00 00 00
00 00
(aprobe0:ahcich1:0:0:0): CAM status: Command timeout
(aprobe0:ahcich1:0:0:0): Error 5, Retries exhausted

A proper image with error showed on screen is here [1] and a dmesg output
obtained using  an USB device with FreeBSD installed on it can be found
here [2].

I mention that on this HDD I have successfully installed Linux Mint
Cinnamon 17.3 64 bit.

What I already did/checked:
- I checked SATA cables (DVD-ROM is connected as well on SATA and works
fine - I can boot from a CD and I tried to switch HDD and DVD-ROM cables).
- I tried another SATA HDD
- I tried different versions of FreeBSD (bootable USB and ISO CDs)
- Modify in BIOS the SATA mode: Native, Legacy and AHCI.
- I managed to install FreeBSD 11.1-Release on another USB device -
unfortunately this is not a solution - it runs very very slow. Also, this
way, I managed to get a dmesg output [2].
- I updated the BIOS.
- I tried what is described here [3]
- The only way this error is not displayed is when I disconnect both HDD
and DVD-ROM.
- BIOS system info is here [4]

Does anyone knows how I can solve this issue?



More information about the freebsd-amd64 mailing list