[Bug 208343] [em] wake on lan not working with Intel I219 V2

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Mar 28 00:17:16 UTC 2016


--- Comment #4 from Eric van Gyzen <vangyzen at freebsd.org> ---
I get the same behavior as Guido.  I'm running head r297219 (24 March) on a
Dell XPS 8900 with an onboard NIC.  To send the WOL packet, I run this on a
neighboring 10.2-RELEASE machine:

    wake bridge0 64:00:6a:80:be:cd

As I mentioned in the mail thread:  In em_get_wakeup(), the eeprom_data is
zero, so adapter->wol stays zero, so ifconfig doesn't show any WOL
capabilities.  When I ignore the eeprom_data by commenting out the "if"
condition, WOL capabilities appear in ifconfig.  However, even when I enable
WOL with ifconfig, WOL still doesn't work after a "shutdown -p now".

em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 64:00:6a:80:be:cd
        inet a.b.c.d netmask 0xffffff80 broadcast e.f.g.h
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active

em0 at pci0:0:31:6:        class=0x020000 card=0x06b81028 chip=0x15b88086 rev=0x31
    vendor     = 'Intel Corporation'
    device     = 'Ethernet Connection (2) I219-V'
    class      = network
    subclass   = ethernet

smbios.system.maker="Dell Inc."
smbios.system.product="XPS 8900"

You are receiving this mail because:
You are on the CC list for the bug.

More information about the freebsd-amd64 mailing list