[Bug 211186] Cannot boot mirrored zpool under 11.0 BETA1

bugzilla-noreply at freebsd.org bugzilla-noreply at freebsd.org
Mon Jul 18 18:43:04 UTC 2016


--- Comment #2 from Dan MacDonald <allcoms at gmail.com> ---
Hi Steven

I ran:

gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ada0
gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ada1

and that fixed booting w/o having my USB drive inserted for the next boot but
unfortunately it was for the next boot only.

After one successful boot, I thought it was fixed so I powered off and
unplugged one drive from the board but I got a very similar (prob the same)
error as the one in the screenshot when I powered on. I powered down again and
tried just having the other drive attached only to get the same result/errors.

I expected that when I plugged both the HDs back in it would boot but it didn't
and now I can't even boot when I have both HDs and the USB drive attached so my
original workaround has stopped working too.

The error screen in the screenshot and the one I'm seeing now both seem to be
expecting to have three drives attached for some reason - it looks like it is
scanning for three to me anyway and I presume that's because of my config
during installation?

When I had Arch installed to a mirrored ZFS pool and booting with grub on this
same machine I was able to unplug either drive and have it successfully boot so
its not a hardware prob.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the freebsd-amd64 mailing list